add purgatory options to status page

VERIFIED FIXED in 5.12.5

Status

addons.mozilla.org Graveyard
Public Pages
P3
normal
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: fligtar, Assigned: jbalogh)

Tracking

Dependency tree / graph

Details

(Whiteboard: [z])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Add-ons in purgatory need a way to get out. We should add another case to this page: http://people.mozilla.com/~chowse/drop/amo/devtools/v3/manage_addon/05_versions.png

<b>Please select a review option.</b>
All add-ons hosted in our gallery must now be reviewed by an editor. If you wish to continue hosting your add-on, please select a review process from the choices below. <a href="https://addons.mozilla.org/en-US/developers/docs/policies/reviews#selection">Learn more about the review choices.</a>
----
[Request Preliminary Review] [Request Full Review] [Disable Add-on] [Delete Add-on]
(Reporter)

Updated

7 years ago
Depends on: 614686
(Reporter)

Updated

7 years ago
Blocks: 612050
(Assignee)

Updated

7 years ago
Assignee: nobody → jbalogh

Comment 1

7 years ago
traceback at /z/en-US/developers/addon/64249/versions/

File "/data/amo_python/www/preview/zamboni/apps/devhub/views.py", line 49, in <lambda>
   fun = lambda: f(request, addon_id=addon_id, addon=addon, *args, **kw)

 File "/data/amo_python/www/preview/zamboni/apps/devhub/views.py", line 635, in version_list
   return jingo.render(request, 'devhub/addons/versions.html', data)

 File "/data/amo_python/www/preview/zamboni/vendor/src/jingo/jingo/__init__.py", line 78, in render
   rendered = render_to_string(request, template, context)

 File "/data/amo_python/www/preview/zamboni/vendor/src/jingo/jingo/__init__.py", line 96, in render_to_string
   return template.render(**get_context())

 File "/usr/lib/python2.6/site-packages/jinja2/environment.py", line 891, in render
   return self.environment.handle_exception(exc_info, True)

 File "/data/amo_python/www/preview/zamboni/apps/devhub/templates/devhub/addons/versions.html", line 3, in top-level template code
   {% set title = _('Versions') %}

 File "/data/amo_python/www/preview/zamboni/apps/devhub/templates/devhub/base.html", line 1, in top-level template code
   {% extends "base.html" %}

 File "/data/amo_python/www/preview/zamboni/templates/base.html", line 85, in top-level template code
   {% block main_content %}

 File "/data/amo_python/www/preview/zamboni/templates/base.html", line 90, in block "main_content"
   {% block content %}{% endblock %}

 File "/data/amo_python/www/preview/zamboni/apps/devhub/templates/devhub/addons/versions.html", line 15, in block "content"
   {% set status_code, status = addon_status(addon) %}

 File "/data/amo_python/www/preview/zamboni/apps/devhub/helpers.py", line 89, in addon_status
   status_code = lookup[addon.status]

KeyError: 10
(Assignee)

Comment 2

7 years ago
http://github.com/jbalogh/zamboni/commit/ce919e5
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

7 years ago
Duplicate of this bug: 617434
(Assignee)

Comment 4

7 years ago
http://github.com/jbalogh/zamboni/commit/7ef9145
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED

Comment 6

7 years ago
Created attachment 498854 [details]
post-fix screenshot
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.