Closed Bug 615804 Opened 9 years ago Closed 9 years ago

Firefox gets stuck in offline mode when switching wifi networks (or losing/regaining network)

Categories

(Firefox :: General, defect)

x86
Windows 7
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 614958

People

(Reporter: kumar, Unassigned)

Details

Whenever I go offline and come back online Firefox remains stuck on offline mode.  This started happening a few days ago with the nightly build and is still reproducible every time.

Steps to reproduce:
* Start up Firefox while connected to your network
* browse around
* Switch wifi networks and wait until connected to the new one
* search google or enter in a URL

It's reproducible every time for me on a Mac.  Also, if I try to quit the browser when it gets into this state I can't, I have to force quit.  I couldn't get the crash reporter to pop up but I caught a crash from Apple and here it is http://pastebin.mozilla.org/871954 

Note: this is similar to bug 534920 but perhaps this one is a bigger problem?
(nevermind the bug reference, I didn't realize it was for Fennec.  I am using desktop Firefox)
OS: Mac OS X → Windows 7
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 614286
Verified duplicate.
Status: RESOLVED → VERIFIED
Duplicate of bug: 614958
You need to log in before you can comment on or make changes to this bug.