checked attribute on checkboxes returns the opposite of what it should

VERIFIED FIXED in M7

Status

()

Core
DOM
P3
normal
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: Steve Morrison, Assigned: Ramiro Estrugo)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: will fix this one tonight (6/16/1999), URL)

(Reporter)

Description

19 years ago
Take a close look at the source to the above url and the 3 lines that look like
this:
document.getElementById('tb_display').checked
return false if checked, and true if not checked. I had to hide this bug in
the interface by calling the checkbox Show instead of Hide. This worked
correctly a while back. If you can't reproduce, take the checked='checked'
attributes off of the 3 <html:input type='checkbox' ... lines in the form, and
try again.

Updated

19 years ago
Assignee: vidur → pollmann

Comment 1

19 years ago
This bugs for you!

Updated

19 years ago
Assignee: pollmann → ramiro

Comment 2

19 years ago
Ramiro, I too am seeing some strangeness in the GTK native widgets.  I'm using a
fresh build from this morning.  The checkbox is not changing state of the first
click, and it is reporting back a state of "checked" when it is not first
checked.

Another test case: (You can peek and poke all DOM attributes here)
blueviper/forms/testDisplay.cgi?element=CheckboxInput
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M6

Comment 3

19 years ago
yes, its a bug in code i wrote.  ill fix it soon. thanks

Comment 4

19 years ago
marking assigned m6.
(Assignee)

Updated

19 years ago
Target Milestone: M6 → M7

Comment 5

19 years ago
marking m7.  i cant make m6 for this bugs.

Comment 6

19 years ago
*** Bug 6881 has been marked as a duplicate of this bug. ***

Comment 7

19 years ago
*** Bug 7695 has been marked as a duplicate of this bug. ***

Comment 8

19 years ago
*** Bug 8051 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Assignee: ramiro → pavlov
Status: ASSIGNED → NEW

Comment 9

19 years ago
I'll fix this one today.

Updated

19 years ago
Status: NEW → ASSIGNED
Whiteboard: will fix this one tonight (6/16/1999)
(Assignee)

Updated

19 years ago
Assignee: pavlov → ramiro
Status: ASSIGNED → NEW

Comment 10

19 years ago
i have a fix for this.

reassignin to myself.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 11

19 years ago
Checked testcase from blueviper. Verified on 1999-07-13-08 build.
You need to log in before you can comment on or make changes to this bug.