Closed Bug 616008 Opened 11 years ago Closed 11 years ago

nanojit tinderbox cannot 'hg update'

Categories

(Release Engineering :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: n.nethercote, Assigned: bhearsum)

Details

Attachments

(3 files, 1 obsolete file)

The nanojit tinderbox (added in bug 506404) has been totally red the last couple of commits.  It appears that 'hg update' is failing on all platforms.  Here's a sample log:

http://tinderbox.mozilla.org/showlog.cgi?log=Nanojit/1291242568.1291242587.16845.gz
Caused by some recent changes to shared code...Catlee and I are figuring out how to fix this.
Assignee: nobody → bhearsum
Untested, but should work. I'll try it in staging today.
I think this everything that needs updating (besides the docs) to cope.
Comment on attachment 494697 [details] [diff] [review]
use different property for ScriptFactory revision

I somehow managed to land the buildbotcustom patch when I was doing other landings today :(. The good news is that it _does_ work. Unfortunately, it's incomplete, I'm going to need a follow-up.
Attachment #494697 - Flags: checked-in+
Attached patch remove doStepIfSplinter Review
Since WithProperties defaults to 'default', we can safely run this step all the time.
Attachment #495066 - Flags: review?(catlee)
Attachment #495066 - Flags: review?(catlee) → review+
Attached patch typo fixSplinter Review
I tested this patch in staging by starting a staging run with release_sanity.py. Both the "update scripts" step and tag-release.py updated to the correct revision.

L10n worked similarly, but I executed it through "Force Build".
Attachment #494698 - Attachment is obsolete: true
Attachment #495081 - Flags: review?(catlee)
Attachment #495081 - Flags: review?(catlee) → review+
Comment on attachment 495081 [details] [diff] [review]
typo fix

changeset:   1819:74254d531776
Attachment #495081 - Flags: checked-in+
Comment on attachment 495066 [details] [diff] [review]
remove doStepIf

Landed in changeset:   1247:0ef69eb28bd1, merged to the production-0.8 branch in 1250:30537b778f04
Attachment #495066 - Flags: checked-in+
Should be all fixed now!
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
(In reply to comment #9)
> Should be all fixed now!

I can confirm that it is fixed, thank you.
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.