When previewing personas, the UI should not move

RESOLVED WORKSFORME

Status

()

Firefox
Theme
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: sdwilsh, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 .x+)

Details

(Whiteboard: [softblocker][pre-approved by beltzner])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
When you preview a persona, the tab strip and toolbars move around.
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
I wasn't able to reproduce this problem with a clean profile nor with a vintage one. Previewing different personas rapidly makes me dizzy, but I didn't see the UI jump around.
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> I wasn't able to reproduce this problem with a clean profile nor with a vintage
> one. Previewing different personas rapidly makes me dizzy, but I didn't see the
> UI jump around.
I saw this on both 3.6 and 4.0 (3.6 had a new profile, but 4.0 did not).
(Reporter)

Comment 3

7 years ago
(In reply to comment #1)
> I wasn't able to reproduce this problem with a clean profile nor with a vintage
> one. Previewing different personas rapidly makes me dizzy, but I didn't see the
> UI jump around.
Also, this may be windows only.  I tested on windows 7.
Can we get confirmation on Win7?
Keywords: qawanted
There was a minor version of this problem in 3.6, but it's worse now, and multi-platform. betaN+
blocking2.0: ? → betaN+
Keywords: regression

Updated

7 years ago
Assignee: nobody → fryn
Status: NEW → ASSIGNED
Whiteboard: [softblocker]

Comment 6

7 years ago
Created attachment 503954 [details]
example of the issue

Made a short video of what I am seeing. On some Personas the whole browser looks to be moving by a few pixels.

Comment 7

7 years ago
Starting work on this.

This bug occurs on at least Windows and OS X (just the add-ons bar for OS X).
Will investigate Linux soon.
OS: Windows 7 → All
Hardware: x86 → All

Comment 8

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b11pre) Gecko/20110127 Firefox/4.0b11pre

Can confirm that the whole browser looks to be moving by a few pixels when switching between default theme and a persona. Between personas this effect is not present.

Updated

7 years ago
Summary: When previewing personas, the UI jumps around → When previewing personas, the UI should not move

Comment 9

7 years ago
Is there a good reason that this blocks betaN?  If not, it should be moved over to final+.
Whiteboard: [softblocker] → [softblocker][final?]

Comment 10

7 years ago
(In reply to comment #9)
> Is there a good reason that this blocks betaN?  If not, it should be moved over
> to final+.

I think this should be final+ too. Fixing this bug only involves making small adjustments to browser/theme/* stylesheets. I've just been testing each platform and UI configuration, ensuring that widths, heights, paddings, borders, and margins are all consistent between non-personas and personas mode.
(Reporter)

Updated

7 years ago
blocking2.0: betaN+ → final+
Whiteboard: [softblocker][final?] → [softblocker]
If a patch appears and passes review, it has implicit a=beltzner
Whiteboard: [softblocker] → [softblocker][pre-approved by beltzner]
** PRODUCT DRIVERS PLEASE NOTE **

This bug is one of 7 automatically changed from blocking2.0:final+ to blocking2.0:.x during the endgame of Firefox 4 for the following reasons:

 - it was marked as a soft blocking issue without a requirement for beta coverage
blocking2.0: final+ → .x+

Comment 13

7 years ago
I think this is fixed by bug 570279.

Comment 14

6 years ago
(In reply to Eddward from comment #13)
> I think this is fixed by bug 570279.

No, it wasn't. For example, the link URL preview bubble in the lower left moves when previewing a lightweight theme with the find bar open.
Assignee: fryn → nobody
Status: ASSIGNED → NEW
I'm unable to reproduce this in that latest Firefox Nightly. Please reopen if this is still an issue.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.