Random crashes in MSVCRT.DLL during opening emails with non-US coding

CLOSED WORKSFORME

Status

MailNews Core
Internationalization
P3
normal
CLOSED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Mirek, Assigned: nhottanscp)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Deatils: M18 build 2000101014, MSVCRT.DLL ver. 6.00.8397.0
Win95, 128MB RAM, Pentium Pro.

Random crashes in MSVCRT.DLL during opening or browsing already opened
emails, almost exclusively those with non-US character coding. The error
occures randomly, sometimes it is reproducible (like starting Mozilla and then
immediately opening the critical email), sometimes it is not. If the mail was
not previously read, then the counter of new (unread) mails stays unaffected,
but the email itself is after the next start marked as read and hence
the counter of unread emails is higher then the true number of unread emails.
At this stage (non-matched number of unread emails with the counter of Inbox),
this type of crash is even more likely, also for US-standard emails.

Additional Feddback:
- The same problems were with previous M17 build.
- I do not recollect these crashes so often on WinNT.

Tech Stuff:
MOZILLA.EXE caused fault #c0000005 in MSVCRT.DLL at address 0157:78001648

To date, 213 fatal errors have been recorded in this program.  This particular
error was recorded 211 times.

Reported By:
CrashGuard v2.0.1

Last Message:
MSG("NSPR:EventReceiver", D5AB, 00000000, 00804430)

Program:
C:\MOZILLA\SEAMONKEY\MOZILLA.EXE
(10/10/00 20:59 - 342240)

Registers:
EAX=0074d1fc CS=0157
EIP=78001648 EFLGS=00010202
EBX=0074d1fc SS=015f
ESP=0068f384 EBP=0068f38c
ECX=3fffac7f DS=015f
ESI=00761ffd FS=0f0f
EDX=00000003 ES=015f
EDI=014f9d70 GS=0000

Bytes at CS:EIP:
f3 a5 ff 24 95 28 17 00 78 8b c7 ba 03 00 00 00

Stack dump:
ffffffff 014e2b20 0068f3c4 6049de44 014e4f70 0074d1fd ffffffff 00000000 0087b8f0
015189d0 0074d1ed 00000015 00000000 0074d1fd 0074d1f0 014e4f70
(Assignee)

Comment 1

18 years ago
Could you try to create a new user profile and see if that's still reproducible?

>almost exclusively those with non-US character coding
Could list the names of charsets?
(Reporter)

Comment 2

18 years ago
1) I have not tried the new profile. But there were similar problems on
the other computer with NT system and M17.
I would prefer not to re-create my profile untill I have to replace
my the computer and start from the scratch anyway ;-)

2) Mainly charset=ISO-8859-2. Rarely charset=ISO-8859-1. I recall
multi-part/alternatice; boundary= to crash as well. I do not recollect
any crash with charset=us-ascii or non-specified charset in the header.

The crash is reproducible only sometimes, like scrolling down the emails
through inbox results in the crash on the particular email almost for sure
while scrolling up throuhout the inbox works fine. In other cases it
cannot be reproduced. The crash is much likely after deletion of previous
email in the list and then during the "autoscroll" to the next one
in the list the crash occurs.

Comment 3

18 years ago
Reporter is this still a problem in the latest nightlies?

Comment 4

18 years ago
Marking WORKSFORME due to lack of response. Reopen if this is still occuring
with a new profile in the latest nightlies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 5

18 years ago
Verified as worksforme.
Please re-open if you come up with a reproducible case.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

18 years ago
The problem has completely vanished with Mozilla0.6/0.7
(even using the old profile). It did not appeared ever since on
any of my machines. Sorry for late posting, I was away.
Thanks everybody. I suggest to close the bug.
Mirek
Status: VERIFIED → CLOSED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.