test_clobberer.py fails in preproduction

VERIFIED FIXED

Status

Release Engineering
General
P2
normal
VERIFIED FIXED
7 years ago
4 years ago

People

(Reporter: rail, Assigned: rail)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

7 years ago
python test_clobberer.py http://preproduction-master.build.mozilla.org/~cltbld/index.php /home/cltbld/public_html/db/clobberer.db
 in dir /builds/buildbot/preproduction/slave/test-masters/tools/clobberer

...

F...............
======================================================================
FAIL: Test that clobbers on release builders with the
----------------------------------------------------------------------
Traceback (most recent call last):
  File "test_clobberer.py", line 372, in testReleaseClobberPrefixBuilder
    self.assert_('release-mozilla-central-linux_build' in data, data)
AssertionError: <html>
<head>
<title>Mozilla Buildbot Clobberer</title>
<link rel="stylesheet" href="clobberer.css" type="text/css" />
<script src="jquery.min.js" language="javascript"></script>
<script language="javascript">
function toggleall(node, klass)
{
  if (klass) {
    $("." + klass).attr("checked", node.checked);
  }
  var node_classes = $(node).attr("class").split(" ");
  if (!node.checked) {
    // If we just unchecked a node, then uncheck the parents too
    for (var i = 0; i < node_classes.length; ++i) {
      if (node_classes[i]) {
        $("#" + node_classes[i]).attr("checked", false);
      }
    }
  } else {
    // If we just checked a node, then possibly check the parents if all
    // children are checked
    var done = false;
    while (!done) {
      done = true;
      for (var i = 0; i < node_classes.length; ++i) {
        if (node_classes[i]) {
          // If none of this class is unchecked, then we can check the parent
          if ($("." + node_classes[i] + ":not(:checked)").length == 0) {
            var p = $("#" + node_classes[i]);
            if (p && !p.attr("checked")) {
              p.attr("checked", true);
              // Loop through again if we just set our parent to checked
              done = false;
            }
          }
        }
      }
    }
  }
}
</script>
</head>
<body>
<p>This page is used for clobbering buildbot-based builds.</p>
<p>Please read
<a href="https://wiki.mozilla.org/Build:ClobberingATinderbox">Build:ClobberingATinderbox</a>
and/or <a href="https://wiki.mozilla.org/Clobbering_the_Tree">Clobbering the Tree</a>
for more information about what this page is for, and how to use it.</p>

<form method="POST">
<table border="1" cellspacing="0" cellpadding="1">
 <thead>
  <tr><td>Branch</td><td>Builder Name</td><td>Slaves</td><td>Last clobbered</td></tr>
 </thead>
 <tbody>
 </tbody>
</table>
<input type="hidden" name="form_submitted" value="true">
<input type="submit" value="Clobber now">
</form>
</body>
</html>

----------------------------------------------------------------------
Ran 16 tests in 13.680s

FAILED (failures=1)
Syed - can you look at this? The failure is on the test you added in https://bug605267.bugzilla.mozilla.org/attachment.cgi?id=487516
Assignee: nobody → salbiz
Status: NEW → ASSIGNED
Priority: -- → P3

Comment 2

7 years ago
Looks like this is due to the REMOTE_USER server variable not being set, so isSpecial comes out false. I can't find a way to set this via the test harness, so it may be faster to set up a preproduction account that is allowed to see release clobbers
(Assignee)

Updated

7 years ago
Assignee: salbiz → rail
Priority: P3 → P2
(Assignee)

Comment 3

7 years ago
$ cat /home/cltbld/public_html/.htaccess 
SetEnv REMOTE_USER armenzg@m.c

(Sorry, Armen, you are the first in the list :) ).


snip from /etc/httpd/conf/httpd.conf:
====================================
<Directory /home/*/public_html>
    AllowOverride All
<Directory>
====================================

I also removed flunkOnFailure=False in http://hg.mozilla.org/build/preproduction/rev/6e5dc6cb7b13
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

7 years ago
http://preproduction-master.build.mozilla.org:8710/builders/test-masters/builds/1014/steps/run_clobbberer_test/logs/stdio is green!
Status: RESOLVED → VERIFIED
(Assignee)

Comment 5

7 years ago
(In reply to comment #3)
> I also removed flunkOnFailure=False in
> http://hg.mozilla.org/build/preproduction/rev/6e5dc6cb7b13

http://hg.mozilla.org/build/preproduction/rev/6c6f2957ef29 actually.
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.