New mail folders appear in subscribed list but not folder list

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: WBT, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101027 Lightning/1.0b2 Thunderbird/3.1.6

When I create a new mail folder on one machine, I can't access it from another machine (running the same TB and settings) without some special workarounds.

Reproducible: Always

Steps to Reproduce:
1. Set up two computers with the same TB and IMAP account settings.  In my case, the IMAP account has a lot of folders.
2. One one machine, create a new subfolder.  
3. On the other machine, where the parent folder is expanded, look at the list of subfolders.  
Actual Results:  
4. Notice that the new subfolder isn't there.
5. Right click on one of the IMAP folders for that account (e. g. Inbox) and choose Subscribe.
6. Browse the folder list and notice that the new folder is listed, and there is a checkbox to indicate that it's been Subscribed to.
7. Unusbscribe from the new folder.
8. Subscribe again to the new folder.
9. Notice that the new folder has appeared in the folder list.
10. Proceed as normal. 

Expected Results:  
4. Notice that the new subfolder is present.
10. Proceed as normal. 

My IMAP structure is as follows:
Inbox
-Drafts
-Sent
-Trash
-Folder1
-Folder2
-Folder3
--Subfolder31
--Subfolder32
--Subfolder33
-Folder4
--Subfolder41
---Subsubfolder411
---Subsubfolder412
---Subsubfolder413
--Sufolder42
-Folder5
-Folder6
Most of these folders were created before getting Thunderbird properly set up on Machine #2.
I observed this bug with the creation of Subfolder33 and Subsubfolder413.
So isn't that just a time constraint issue. How long do you wait between doing 2 and 3 ?

Is autoSync enabled on your configurations ?
(Reporter)

Comment 2

7 years ago
As long as a count of days.  I just created a test folder on Machine A and I can check whenever you'd like me to on Machine B.  I'm not sure what exactly you mean by AutoSync, because when I view messages it usually needs a server connection to do so.  Can you tell me more details on what to check?
Thanks.

Comment 3

7 years ago
Have you tried 3.1.7? I believe this is a dup of an existing bug that has been fixed.
(Reporter)

Comment 4

7 years ago
On upgrading to 3.1.7, TB (on Machine B) found the new folder and displayed it but did not subscribe to it.
After both machines finished upgrading, I created a new folder on Machine A that was not visible on Machine B until after a restart of TB (hours allowed before trying the restart) even though it still shows up in the list of subscribed folders as one that's subscribed to.  
It's nice to see that restarting seems to work in 3.1.7, but it's odd that a folder Thunderbird thinks it's subscribed to doesn't appear in the list until an unsubscribe and resubscribe operation.

Comment 5

6 years ago
Reporter, 

do you still see this problem when using a current version of thunderbird? 

And if you do not, please close bug report by changing resolution to worksforme
Whiteboard: [closeme 2012-03-01]
(Reporter)

Comment 6

6 years ago
I'm not set up to test the new version because I still need TB3 in order to do filter import & export / synchronization.  (With this many folders and filters on multiple machines, I can't be manually adjusting the filter rules on each one independently.)
Either somebody else should give it a good test using the information above, or the bug should stay open.
Whiteboard: [closeme 2012-03-01]

Comment 7

6 years ago
WFM current daily build - folder removed on work PC, doesn't appear on home PC
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.