[SeaMonkey] Disable screensaver on Linux

REOPENED
Unassigned

Status

SeaMonkey
Release Engineering
REOPENED
7 years ago
3 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
I'm not thinking about any specific (random) test failure,
but I simply assume we may want to do as in bug 585286.

And I'm always reminded about this when I check for (unrelated) bug 589471:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1291276384.1291277467.17882.gz&fulltext=1
Linux comm-central-trunk debug test mochitests-5/5 on 2010/12/01 23:53:04
{
XScreenSaver state: On
XScreenSaver kind: Blanked
XScreenSaver idle timer activated 3073493 seconds ago
User input has been idle for 3074093 seconds
}

NB: I don't know about MacOSX and Windows boxes...

Comment 1

7 years ago
Hmm, I actually thought screen savers were off on all our machines anyhow...

Comment 2

7 years ago
I tried to take a look but can't really find what to look for or what to change there.

Ben, can you help me on what we need there? Do the FF boxes have some special settings there? (Note that those are CentOS machines, we don't have Fedora talos machines)
I have no idea. jhford might know.
(Reporter)

Comment 4

7 years ago
Bug 616175 may give a hint...
(Reporter)

Comment 5

7 years ago
(In reply to comment #4)
> Bug 616175 may give a hint...

Arg, bug 601783 !

Comment 6

7 years ago
Somehow sounds like bug 585286 fixed that in general, probably only on the 0.8 branch though, so this might be dependent on bug 567035 in the end.
(Reporter)

Updated

7 years ago
Depends on: 567035
Summary: Disable screensaver on Linux → [SeaMonkey] Disable screensaver on Linux

Comment 7

7 years ago
I hope this is fixed now by bug 567035, please reopen if it isn't.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Updated

7 years ago
Assignee: nobody → kairo
Flags: in-testsuite-
(Reporter)

Comment 8

7 years ago
Bug 589471 is worked around ftb, so there isn't an obvious log to verify atm.
(Reporter)

Comment 9

7 years ago
Not fixed:

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1292648850.1292653105.26076.gz
Linux comm-central-trunk debug test mochitests-4/5 on 2010/12/17 21:07:30
{
2833 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/generic/test/test_movement_by_characters.html | Test timed out.
args: ['/builds/slave/test/build/bin/screentopng']
XScreenSaver state: On
XScreenSaver kind: Blanked
XScreenSaver idle timer activated 1922 seconds ago
User input has been idle for 2522 seconds
}

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1292663840.1292669312.24200.gz&fulltext=1
Linux comm-central-trunk debug test mochitests-4/5 on 2010/12/18 01:17:20
{
2833 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/generic/test/test_movement_by_characters.html | Test timed out.
args: ['/builds/slave/test/build/bin/screentopng']
XScreenSaver state: On
XScreenSaver kind: Blanked
XScreenSaver idle timer activated 3689 seconds ago
User input has been idle for 4289 seconds
}

I don't know whether this is the cause of this test failure (but could be),
anyway let's rule this out.

***

Ftr,
{
======== BuildStep started ========
'xset s ...'
=== Output ===
xset s reset
 in dir /builds/slave/test/build (timeout 1200 secs)
...
program finished with exit code 0
elapsedTime=0.879665
=== Output ended ===
======== BuildStep ended ========
}

Could you check what that command actually do?
(Maybe CentOS needs a different command than Fedora?)
Blocks: 489560
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 10

7 years ago
Bug still there:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1295285098.1295286411.30426.gz
Linux comm-central-trunk debug test mochitests-5/5 on 2011/01/17 09:24:58
without looking heavily, and being only on windows, man for xset seems to indicate we want to |xset s reset| and then |xset s off| (since reset only cancels the screensaver from being active at that moment, if it was active).
(Reporter)

Comment 12

7 years ago
Fwiw, |xset q| gives information on the current settings.

Buildbot step does |xset s reset| :-|
Maybe our boxes miss |xset s off| in some init config?
Or maybe a buildbot step should do it (too)?
(Reporter)

Comment 13

7 years ago
Or the difference might be in the length:
SeaMonkey seems to use 600 seconds (= 10 mn),
which, iirc, may be less than the 1200(!?) seconds that buildbot uses as a timeout delay...

I don't know what length Firefox uses.
(Reporter)

Updated

7 years ago
Component: Testing Infrastructure → Release Engineering
QA Contact: testing-infrastructure → release
self fyi: http://www.linuxquestions.org/questions/linux-software-2/how-to-disable-screensaver-for-some-applications-36318/

Updated

7 years ago
Assignee: kairo → nobody
You need to log in before you can comment on or make changes to this bug.