Closed Bug 616179 Opened 11 years ago Closed 11 years ago

Persona not displayed after pref sync cleanup

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: moz.teodosia, Assigned: philikon)

References

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101202 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101202 Firefox/4.0b8pre

After sync, if a persona is used, it's shown as changed to the correct persona in Add-ons Manager, but FF doesn't display it, not even on restart. 

Reproducible: Always

Steps to Reproduce:
1.Install a persona on one of the computers.
2.Sync the computers
Actual Results:  
The synced persona is not displayed, but it appears in Add-ons Manager.

Expected Results:  
FF should display the persona.
This is a regression. I also see it on XP and Mac minefield nightly builds.
Keywords: regression
OS: Windows 7 → All
Hardware: x86 → All
Blocks: 560580
Component: General → Firefox Sync: Backend
Product: Firefox → Mozilla Services
QA Contact: general → sync-backend
Summary: Persona is not displayed after Sync → Persona not displayed after pref sync cleanup
Attached patch v1Splinter Review
Had forgotton to update the LTM code paths. They wouldn't show up in tests or logs since they're try-catch'ed for Firefox 3.5 compat. Also: yay for shoddy test coverage.

Tracy confirmed that this patch fixes the problem.
Assignee: nobody → philipp
Attachment #494748 - Flags: review?(mconnor)
Attachment #494748 - Flags: review?(mconnor) → review+
https://hg.mozilla.org/services/fx-sync/rev/37150bc0bf62
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Verified with minefield nightly of 20101203
Status: RESOLVED → VERIFIED
Blocks: 617173
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.