If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

HWACCEL demo much slower with layers.accelerate-all on than with layers.accelerate-all off

RESOLVED DUPLICATE of bug 611596

Status

()

Core
Graphics
--
major
RESOLVED DUPLICATE of bug 611596
7 years ago
7 years ago

People

(Reporter: Jeff Cook, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101201 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101201 Firefox/4.0b8pre

Mozilla's HWACCEL demo is much slower for me with layers.accelerate-all on than with layers.accelerate-all off. I get ~15 FPS with layers.accelerate-all on and ~90 FPS with layers.accelerate-all off. Other websites demonstrate a similarly drastic slowdown as well.

Reproducible: Always

Steps to Reproduce:
1. Toggle layers.accelerate-all
2. Restart Firefox
3. Observe speed difference
Actual Results:  
Compositing is much slower than XRENDER acceleration

Expected Results:  
Compositing should match or exceed XRENDER acceleration in speed

I am using a nightly from Dec. 2. I have a GeForce GTX 285 with nvidia blob 260.19.21 drivers. I am using a current ArchLinux installation with kernel 2.6.36.
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 611596
You need to log in before you can comment on or make changes to this bug.