Search engine logo on about:home needs alternate text

RESOLVED WORKSFORME

Status

()

Firefox
General
--
trivial
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Michael, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [about-home], URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b8pre) Gecko/20101129 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b8pre) Gecko/20101129 Firefox/4.0b8pre

Images on the about:home page should have tooltips to aid in access for people with disabilities or those that have images disabled.

None are present when the images are hovered over

Reproducible: Always

Steps to Reproduce:
1.  Type in about:home in address bar
2.  Hover over some of the images
Actual Results:  
Tooltips are not present on images.

Expected Results:  
A tool tip describing the images should have appeared when hovering over the image.
The search engine logo's alternate text should be the engine's name. The other image (Firefox logo) doesn't really need alt text since it's just accompanying the text "Firefox Start".
Component: Disability Access → General
QA Contact: disability.access → general
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Images on the about:home page lacking tooltips on hover over. → Search engine logo on about:home needs alternate text
Oh, we already set image.alt = engine.name. It doesn't show as a tooltip intentionally (bug 25537).
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
See also bug 594183

Updated

7 years ago
Whiteboard: [about-home]
You need to log in before you can comment on or make changes to this bug.