Password sync failed: NS_ERROR_XPC_JS_THREW_STRING

RESOLVED WORKSFORME

Status

Cloud Services
Firefox Sync: Backend
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: Bill Canton, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 AlexaToolbar/alxf-1.54 Firefox/3.6.12 GTB7.1
Build Identifier: 3.6.12

Error While Syncing - 

Reproducible: Always

Steps to Reproduce:
1.Click Sync Now
2.Click Sync Now
3.Click Sync Now
Actual Results:  
Shows error while Syncing

Expected Results:  
SHown a sync complete or some information confirming syncing

Comment 1

7 years ago
Created attachment 500792 [details]
error while syncing log file

99% of the time get "error while syncing".  Have 2 desktops and 2 laptops that I attempt to sync.  Log file from one desktop attached.
(In reply to comment #1)
> Created attachment 500792 [details]
> error while syncing log file

Thanks for your logs, but "Error While Syncing" is a very generic error. So you could be experiencing a problem much different from what Bill is seeing. That's why it's always better to file a *new* bug. Worst thing that can happen is that we dupe it to an existing one iff they are the same.

> 99% of the time get "error while syncing".  Have 2 desktops and 2 laptops that
> I attempt to sync.  Log file from one desktop attached.

A password record seems to be bogus. The log at this level doesn't show what it is, for obvious reasons. You can turn on trace logging for password sync, though:

1. Go to about:config and set services.sync.log.logger.engine.passwords to Trace
2. Restart the browser, sync again and observe the error message.
3. Go to about:sync-log and about:sync-log.1, save those files and attach them or send them to us. Careful! Those files will contain your passwords so you might want to replace those with random data first.

Comment 3

7 years ago
I have this same error.  There is no more information other than "Error While Syncing".  The odd thing is, it's working fine on my other Win 7 x64 bit computer....both os'es are the same.
(In reply to comment #3)
> I have this same error.

When you say the same error, do you mean the same error message in the logs or just the error message in the notification bar at the bottom of the browser?

If the latter, please file a *new* bug and attach the output of about:sync-log.
Summary: Error While Syncing → Password sync failed: NS_ERROR_XPC_JS_THREW_STRING

Updated

5 years ago
Component: Firefox Sync: Build → Firefox Sync: Backend
Stale. Please reopen if this is still happening.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.