Closed Bug 616495 Opened 9 years ago Closed 9 years ago

Firefox 4.0b8pre crash in [@ nsCSSBorderRenderer::DrawRectangularCompositeColors() ][@ nsCSSBorderRenderer::DrawRectangularCompositeColors ]

Categories

(Core :: Layout, defect, critical)

x86
All
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- beta8+

People

(Reporter: marcia, Assigned: bas.schouten)

References

Details

(Keywords: crash)

Crash Data

Attachments

(2 files)

Seen while reviewing new crashes. This crash started showing up in crash stats using the 2010120300 build. So far crashes are Win 7 and XP only. http://tinyurl.com/26eljvm to the crashes so far.

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsCSSBorderRenderer::DrawRectangularCompositeColors 	layout/base/nsCSSRenderingBorders.cpp:1334
1 	xul.dll 	nsCSSBorderRenderer::DrawBorders 	
2 		@0x3fefffff
Duplicate of this bug: 616510
Can we get some urls for this crash? It seems likely to reproducible with
particular content.
9987d0724a10
2010-12-02 14:17 +0100	Bas Schouten - Bug 588271 - Part 4: Add specialized rendering codepaths for the most common border types. r=vlad a=blocking-betan
Problem has been rootcaused. Working on a fix. Surprising this is so rare, really.
This should block beta 8.
blocking2.0: --- → ?
Assignee: nobody → bas.schouten
Status: NEW → ASSIGNED
Attachment #495059 - Flags: review?(vladimir)
Test please.
blocking2.0: ? → beta8+
Comment on attachment 495059 [details] [diff] [review]
Deal with some border sides having no moz-border-colors while others do

looks fine, but as jeff said, add a test pls!
Attachment #495059 - Flags: review?(vladimir) → review+
As requested, a test.
Attachment #495076 - Flags: review?(vladimir)
Comment on attachment 495076 [details] [diff] [review]
Test single side composite color border

nitpick: Call the test 616495-single-side-composite-color-border.html or something like that
Attachment #495076 - Flags: review?(vladimir) → review+
OS: Windows XP → All
Summary: Firefox 4.0b8pre crash in [@ nsCSSBorderRenderer::DrawRectangularCompositeColors() → Firefox 4.0b8pre crash in [@ nsCSSBorderRenderer::DrawRectangularCompositeColors() ][@ nsCSSBorderRenderer::DrawRectangularCompositeColors ]
http://hg.mozilla.org/mozilla-central/rev/cd392793b0c0
http://hg.mozilla.org/mozilla-central/rev/ec5c700a5f7e
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Crash Signature: [@ nsCSSBorderRenderer::DrawRectangularCompositeColors() ] [@ nsCSSBorderRenderer::DrawRectangularCompositeColors ]
You need to log in before you can comment on or make changes to this bug.