Random failure to find newsgroups on server

RESOLVED DUPLICATE of bug 235978

Status

RESOLVED DUPLICATE of bug 235978
8 years ago
8 years ago

People

(Reporter: Mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101027 Thunderbird/3.1.6

Some subscribed newsgroups are reported as not being found on server and asking for OK to unsubscribe.  May very well be another 'feature' of 'bug 577022: Newsgroups subscription filter fails on first character'

Reproducible: Sometimes




Posting messages to a newsgroup may take too long, and will actually result in a time-out error.  The message has been accepted in these cases, although the error infers it failed.
Can you provide NNTP logs of a session where this happens?
<https://wiki.mozilla.org/MailNews:Logging>
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Can you provide NNTP logs of a session where this happens?
> <https://wiki.mozilla.org/MailNews:Logging>

I enabled the nntp logging, and have captured several logs of when a newsgroup will not be found.  Those, and also a screen dump of one such failure, can be found (I hope) at
     http://frontiernet.net/~321st/mozilla/
The 4 smaller logs (nntp_5.log thru nntp_7.log) were immediate failures when Thunderbird was executed.  The other logs represent a much longer time frame.  This is a very random event.

Executing Thunderbird in SAFE mode had no effect on this (did have an instance of a newsgroup not being found.)

I have not captured a log file yet where the posting of a message times out.

Bob K
Okay, given the logs, it seems that your news provider is sometimes telling you that the given group does not exist:
> 0[182c140]: (47f3320) Next state: NNTP_RESPONSE
> 0[182c140]: (47f3320) Receiving: 411 No Such Group "mailing-list.slackware"

This is an issue that you should bring up with your news provider.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 235978
(Reporter)

Comment 4

8 years ago
Not really sure this should be a duplicate of bug 235978.  That bug deals with the results of these unsubscribe pop-ups.  My complaint is their happening in the first place -- since they are bogus.

It is correct the logs report a "no such group" reply from the server.  However, the server apparently has a dislike for Thunderbird!  With an earlier problem (bug 577022) I had contacted my ISP first, and they could not duplicate it using Outlook Express.  So, to use their approach, I have run Outlook Express here at the same time as the Thunderbird, accessing maybe fewer newsgroups, but otherwise as equal as I could make it.

I received, over a 1/2 day run, many errors from Thunderbird, and none from OE.  So, there is a difference somewhere!  Keep in mind this is the same machine, the same CPU loads, and such.

I did see in setting up OE, which I had not used before, a "server timeout" setting that is currently set to 1 minute.  Is there an equivalent setting for Thunderbird, and if so, how do I modify it?

I object to the status being set to RESOLVED.  From my standpoint, until I can correct a very objectionable situation, it is not resolved.  My ISP has already suggested I switch to a different news reader.  Is that the answer?

Bob K
(In reply to comment #4)
> Not really sure this should be a duplicate of bug 235978.  That bug deals with
> the results of these unsubscribe pop-ups.  My complaint is their happening in
> the first place -- since they are bogus.

The issue is that the news server is telling us that they don't exist. Bug 235978 also mentions that a few group not founds are transient on their parts.

> I did see in setting up OE, which I had not used before, a "server timeout"
> setting that is currently set to 1 minute.  Is there an equivalent setting for
> Thunderbird, and if so, how do I modify it?

The timeout is hardcoded for 170 seconds. More likely, the max connection limit might cause more problems (which can be changed in the server settings page).

> I object to the status being set to RESOLVED.  From my standpoint, until I can
> correct a very objectionable situation, it is not resolved.  My ISP has already
> suggested I switch to a different news reader.  Is that the answer?

This is a duplicate of an unresolved bug, so it's not exactly RESOLVED. :-)

Unfortunately, the primary problem is that your ISP has a buggy newsserver. Thunderbird is performing only valid NNTP accesses, so if it is lying to us, it's because their server is broken, even if they are unwilling to test it themselves.
You need to log in before you can comment on or make changes to this bug.