Mozilla M5 GPFs on startup.

VERIFIED DUPLICATE of bug 7802

Status

SeaMonkey
Build Config
P3
major
VERIFIED DUPLICATE of bug 7802
20 years ago
11 years ago

People

(Reporter: Marcus Pallinger, Assigned: Nisheeth Ranjan)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Hi,
Mozilla M5GPFs on startup on our Windows 95 System. It appears to be an
unpatched origional windows 95 (Windows 4.00.950) with Plus.

These are the messages printed in the DOS window.
=====

nsComponentManager: Using components dir: C:\MARCUS\MOZILLA-M5-FULLCIRCLE\X86R
\components
width was not set
height was not set
                defaultReading file...
Reading file...Done
The Messenger component is available. Initializing...
Messenger has been bootstrapped!
The Composer component is available. Initializing...
Composer has been bootstrapped!
Reading file...
Reading file...Done
Reading file...
Reading file...Done

====
By this stage, Mozilla has Has drawn the screen (Tool bar with Back, Forward,
Reload, Stop, Toolbar with Home, My Netsape, and the Status bar/toolbar at the
bottom) Menus are not visible yet.

This is the message from the GPF.
APPRUNNER caused an invalid page fault in
module RAPTORBASE.DLL at 0137:0044c365.
Registers:
EAX=00000000 CS=0137 EIP=0044c365 EFLGS=00010246
EBX=0077f244 SS=013f ESP=0077f168 EBP=0077f194
ECX=00000001 DS=013f ESI=00000000 FS=0f5f
EDX=00000003 ES=013f EDI=0044bc26 GS=0000
Bytes at CS:EIP:
c6 46 02 78 e8 56 0e 00 00 8b f8 59 c6 46 02 7c
Stack dump:
00000000 00000004 0044bc26 0077f240 00af9480 0044c3af 0077f18c 0044bc26 0077f240
00452dc4 00000000 0077f288 0044c2bf 0077f234 80000000 01279a1c

the fault was submitted via fullCircle as id: EJH45PTQ

The bug was still present in the nightly build dated
Sun May 09 13:58:00 1999 Zip Compressed Data
from
ftp://ftp.mozilla.org/pub/mozilla/nightly/last-built/

This bug is also present in all the recent nightly builds that I tried (about a
week before the release of M5). M4 was unaffected.

Please don't hesitate to contact me if you need more information.

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WORKSFORME

Comment 1

20 years ago
Try the following (it's a known problem/workaround):

> del c:\windows\mozregistry.dat

and then try to start apprunner again. If that doesn't work, then
REOPEN this bug (but I think it will work).
(Reporter)

Updated

20 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 2

20 years ago
I removed c:\windows\mozregistry.dat
This did not fix the problem (Overnight build, same version as before (9 may
99))

From the TextWindow:
========
nsComponentManager: Using components dir: C:\MARCUS\MOZILLA-WIN32\BIN\components

*** XPInstall is being registered
width was not set
height was not set
Reading file...
Reading file...Done
The Messenger component is available. Initializing...
Messenger has been bootstrapped!
The Composer component is available. Initializing...
Composer has been bootstrapped!
Reading file...
Reading file...Done
Reading file...
Reading file...Done
Reading file...
Reading file...Done
Doing Startup...
Creating browser app core
BrowserAppCore has been created.
Setting content window
======

From the GPF Message box (Details button)
======
APPRUNNER caused an invalid page fault in
module RAPTORBASE.DLL at 0137:0044c1ff.
Registers:
EAX=00000000 CS=0137 EIP=0044c1ff EFLGS=00010246
EBX=0077bef8 SS=013f ESP=0077be1c EBP=0077be48
ECX=00000001 DS=013f ESI=00000000 FS=3297
EDX=00000003 ES=013f EDI=0044bb0c GS=0000
Bytes at CS:EIP:
c6 46 02 78 e8 7d 0e 00 00 8b f8 59 c6 46 02 7c
Stack dump:
00000000 00000004 0044bb0c 0077bef4 00a70a00 0044c249 0077be40 0044bb0c 0077bef4
00451dc4 00000000 0077bf3c 0044c181 0077bee8 80000000 00d49aa5
======

Updated

20 years ago
Component: other → Build Config
QA Contact: 3853 → 2433
Resolution: WORKSFORME → ---

Updated

20 years ago
Assignee: chofmann → briano
Status: REOPENED → NEW

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED

Comment 3

20 years ago
I believe this is fixed now.  As far as I know, this isn't happening
in the latest builds.  Also, M6 will be released next week (hopefully),
so that should take care of this for you.

CC'ing leaf for his input on this, since he's more familiar with the
Windows builds than I am.

Comment 4

20 years ago
unfortunately, i have no way to test this anymore (i'm all broken up about not
having my win 9x box, let me tell you)... marcus?
(Reporter)

Updated

20 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 5

20 years ago
Hi again.
Alas, it hasn't worked :(
build date and time: Thu May 13 13:59:00 1999
Status window (or hwatever it's calleD)

*** Registering html library
width was not set
height was not set
Reading file...
Reading file...Done
Reading file...
Reading file...Done
The Messenger component is available. Initializing...
Messenger has been bootstrapped!
The Message Compose component is available. Initializing...
Composer has been bootstrapped!
Reading file...
Reading file...Done
Reading file...
Reading file...Done

APPRUNNER caused an invalid page fault in
module RAPTORBASE.DLL at 0137:0044b5ee.
Registers:
EAX=00000000 CS=0137 EIP=0044b5ee EFLGS=00010246
EBX=0078f25c SS=013f ESP=0078f160 EBP=0078f188
ECX=00000001 DS=013f ESI=00000000 FS=10a7
EDX=00000003 ES=013f EDI=0044ae86 GS=0000
Bytes at CS:EIP:
c6 46 02 78 e8 4f 22 00 00 8b f8 59 c6 46 02 7c
Stack dump:
00000000 00000004 0044ae86 0078f258 0044f30e 0044b637 0078f180 0078f258 00452c3c
00000000 0078f280 0044b570 0078f228 80000000 00da7616 0078f228

Later on in the day (our time), I'll do a fresh reboot and try it again (this
hasn't fixed anythign in the past though
As usual if there is anythign else you want me to provide (Screenshot, more data
 and so on) please let me know.

Updated

20 years ago
Assignee: briano → kipp
Status: REOPENED → NEW
Target Milestone: M6

Comment 6

20 years ago
Reassigning to Kipp in the hope that this will make more sense
to him than to me....

Updated

20 years ago
Assignee: kipp → nisheeth

Comment 7

20 years ago
Of course we need a stack crawl to even have a clue here; and I'm going on
sabbatical so I'm reassigning it to nisheeth to look into.
(Reporter)

Comment 8

20 years ago
The PC with the problem has no development tools on it. How would I go about
performing a stack crawl? The next time I have access to the PC is Monday
Morning (our time) about Sunday afternoon your time. I'll try the lates build
then, I'll also reboot and hold shift (so that it doesn't load the Startup group
and so on). But this hasn't done much in the past. If you have any other
sugestions on whart to try ar my end, let me know (Safe mode with network
support perhaps?)
(Reporter)

Comment 9

19 years ago
I did some more testing at home. I decided to try run Mozilla there, and I got
the same kind of GPF. I then decided to re-install Windows 98 on the machine to
see if it was anythign weird that I had installed.
I started with Win 98 lite <URL: http://www.98lite.net/> Basically Windows 98
without Windows Explorer. I then installed Winzip (can't remmeber the version)
uncompressed Mozilla so that it sat in c:\bin (that's the directory where
aprunner sits)
I tried to start apprunner, and got a message saying that it couldn't find
msvcirt.dll. I then installed Netscape Navigator (not communicator) 4.06.
I then ran apprunner again, and it GPFed at the same point.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M6 → M7
(Assignee)

Comment 10

19 years ago
I have some other M6 bugs that are of higher priority because they occur on all
platforms.  Hopefully, this problem will get fixed by the M6 release.  If not,
we can attack this for M7...

Updated

19 years ago
Resolution: FIXED → ---
(Assignee)

Comment 11

19 years ago
Marcus, please download the M6 release from
http://www.mozilla.org/projects/seamonkey/release-notes/index.html and see if
that fixes your problem.  If not, lets try to figure this out in time for M7 so
that you can start using Gecko.  Thanks.
(Reporter)

Comment 12

19 years ago
Nope it died again. :(
A Fullcircle crash report was sent (I forgot to grab the number, but i made a
reference to this bug number in the description).

Basically it ran once, asked for the profiles stuff, then exited. I ran it
again, and the GPF happened...

I even tried to download the updated librarys
<URL:http://www.microsoft.com/windows95/downloads/>
From the page:
Windows Library Update
This update resolves an issue that can cause some third party software to behave
unexpectedly.

That didn't fix it.
One thing both computers seem to share is that neither seems to have
Internet Explorer instaleld on them (the work one is the origional version of
Windows 95 (which i believe didn't come out with IE) and the otehr is Windows 98
installed with 98lite, which removes IE. (I can't think of anythign else they
seem to have in common... One was even a fresh reinstall of 98lite, Mozilla and
navigator 4.06 (not communicator).

If you need more info, jsut give me a yell...
(Reporter)

Comment 13

19 years ago
Sorry aobut the second email.
The Full Circle Incident ID is:
TB9418300G

Comment 14

19 years ago
Talkback Incident #9202988 was found...but having trouble get trace.  Waiting
for cyclone server to come back up.  Then will add data.

Updated

19 years ago
QA Contact: cyeh → paulmac

Comment 15

19 years ago
Here it is:

 Call Stack:    (Signature = RAPTORHTML.DLL + 0x25ced (0x01545ced) 09b530e7)

   RAPTORHTML.DLL + 0x25ced (0x01545ced)


   RAPTORHTML.DLL + 0x25dd6 (0x01545dd6)


   RAPTORHTML.DLL + 0x2550b (0x0154550b)


   RAPTORHTML.DLL + 0x25499 (0x01545499)


   RAPTORHTML.DLL + 0x84e71 (0x015a4e71)


   RAPTORHTML.DLL + 0x216f0 (0x015416f0)


   RDF.DLL + 0x15163 (0x01635163)


   RDF.DLL + 0x132ad (0x016332ad)


   RAPTORHTMLPARS.DLL + 0xe2a9 (0x012ee2a9)


   RAPTORHTMLPARS.DLL + 0xaf7d (0x012eaf7d)


   RAPTORHTMLPARS.DLL + 0xb3ba (0x012eb3ba)


   RAPTORHTMLPARS.DLL + 0xafe8 (0x012eafe8)


   RDF.DLL + 0x21248 (0x01641248)


   NETLIB.DLL + 0x3cce (0x00473cce)


   RAPTORWEB.DLL + 0x2a1b (0x01272a1b)


   NETLIB.DLL + 0x298c (0x0047298c)


   NETLIB.DLL + 0x2817 (0x00472817)


   PLDS3.DLL + 0x18ee (0x004118ee)


   PLDS3.DLL + 0x186a (0x0041186a)


   PLDS3.DLL + 0x1af8 (0x00411af8)


   KERNEL32.DLL + 0x363b (0xbff7363b)


   KERNEL32.DLL + 0x242e7 (0xbff942e7)


   0x00788c3e

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago19 years ago
Resolution: --- → DUPLICATE

Comment 16

19 years ago
Moving stack crawl to overall Crash on Launch Bug:
http://bugzilla.mozilla.org/show_bug.cgi?id=7802

Moving this to Verified/Dup

*** This bug has been marked as a duplicate of 7802 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

11 years ago
URL: N/A
You need to log in before you can comment on or make changes to this bug.