Last Comment Bug 616516 - Intermittent failure in layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
: Intermittent failure in layout/reftests/svg/smil/anim-rect-rxry-1.svg | image...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All Windows XP
: -- normal (vote)
: ---
Assigned To: Robert Longson
:
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2010-12-03 10:13 PST by Mounir Lamouri (:mounir)
Modified: 2012-11-25 19:31 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
reftest log (22.20 KB, text/plain)
2010-12-03 10:26 PST, Daniel Holbert [:dholbert]
no flags Details
possible fix (1.39 KB, patch)
2011-05-13 02:19 PDT, Robert Longson
dholbert: review+
Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2010-12-03 10:13:07 PST
s: talos-r3-w7-016
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/mozilla-central_win7_test-reftest/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1291395719.1291398525.11587.gz
Comment 1 Daniel Holbert [:dholbert] 2010-12-03 10:26:05 PST
Created attachment 495040 [details]
reftest log

Here's the reftest log, suitable for passing to http://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml

The difference is visually undetectable, unless you zoom in pretty far. It's a slight fuzziness difference along the inner & outer edges of the stroke on...
 - the lower-left circle's upper-right corner
 - the lower-right circle's lower-left corner
Comment 2 Treeherder Robot 2010-12-03 17:46:31 PST
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1291424195.1291426814.15066.gz
Rev3 WINNT 6.1 mozilla-central opt test reftest on 2010/12/03 16:56:35

s: talos-r3-w7-041
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/mozilla-central_win7_test-reftest/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 3 Treeherder Robot 2010-12-03 17:46:31 PST
masayuki%d-toybox.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1291424195.1291426814.15066.gz
Rev3 WINNT 6.1 mozilla-central opt test reftest on 2010/12/03 16:56:35

s: talos-r3-w7-041
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/mozilla-central_win7_test-reftest/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 4 Treeherder Robot 2010-12-09 05:25:07 PST
mak77%bonardo.net
http://tinderbox.mozilla.org/showlog.cgi?log=Places/1291898409.1291900721.20240.gz
WINNT 5.2 places debug test reftest on 2010/12/09 04:40:09

s: w32-ix-slave22
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/places-win32-debug-unittest-reftest/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 5 Treeherder Robot 2010-12-09 11:06:43 PST
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1291918938.1291921323.14765.gz
Rev3 WINNT 6.1 mozilla-central opt test reftest on 2010/12/09 10:22:18

s: talos-r3-w7-031
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/mozilla-central_win7_test-reftest/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 6 Jonathan Watt [:jwatt] (catching up after vacation) 2010-12-09 11:45:19 PST
Note that the failure is in different pixels in the NT 5.2 vs 6.1 results (same two rects though).
Comment 7 Brian Birtles (:birtles) 2010-12-09 16:41:57 PST
The problem is only Windows, and, as mentioned in bug 606399 which introduced this test case, may be some interaction with layers. Rendering differences sometimes occur on content that is entirely identical in markup between reference and test file and is unanimated. One hypothesis is that some nearby content is animated causing unanimated content to be promoted to a layer and bringing about differences in rendering.

Forcing a synchronous sample seems to have reduced the frequency of this problem but not eliminated it.

A further avenue might be to try using setTimeout to see if that gives us a more stable state for snapshot.
Comment 8 Treeherder Robot 2010-12-17 01:57:55 PST
mounir.lamouri%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1292545567.1292549191.8725.gz
WINNT 5.2 tryserver debug test reftest on 2010/12/16 16:26:07

s: w32-ix-slave05
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/test/build/reftest/tests/content/html/content/reftests/autofocus/button-load.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/test/build/reftest/tests/content/html/content/reftests/autofocus/button-create.html | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 9 Treeherder Robot 2011-03-10 18:49:34 PST
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1299808976.1299811479.2400.gz
Rev3 WINNT 5.1 tracemonkey debug test reftest on 2011/03/10 18:02:56

s: talos-r3-xp-023
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 10 Treeherder Robot 2011-03-23 11:42:39 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1300902751.1300904335.2359.gz
Rev3 WINNT 5.1 mozilla-central opt test reftest on 2011/03/23 10:52:31

s: talos-r3-xp-029
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 11 Treeherder Robot 2011-03-23 17:31:06 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1300923533.1300926374.6961.gz
Rev3 WINNT 5.1 mozilla-central debug test reftest on 2011/03/23 16:38:53

s: talos-r3-xp-026
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 12 Treeherder Robot 2011-03-24 18:41:15 PDT
khuey
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1301013961.1301016966.13079.gz
Rev3 WINNT 5.1 mozilla-central debug test reftest on 2011/03/24 17:46:01

s: talos-r3-xp-053
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 13 Treeherder Robot 2011-03-24 18:42:00 PDT
khuey
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1301013961.1301016966.13079.gz
Rev3 WINNT 5.1 mozilla-central debug test reftest on 2011/03/24 17:46:01

s: talos-r3-xp-053
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 14 Treeherder Robot 2011-03-28 10:09:40 PDT
dholbert%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1301327464.1301330231.30782.gz
Rev3 WINNT 5.1 mozilla-central debug test reftest on 2011/03/28 08:51:04

s: talos-r3-xp-053
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 15 Treeherder Robot 2011-03-31 14:36:11 PDT
cjones
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1301604702.1301606130.13802.gz
Rev3 WINNT 5.1 mozilla-central opt test reftest on 2011/03/31 13:51:42

s: talos-r3-xp-015
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 16 Treeherder Robot 2011-04-01 11:33:59 PDT
bill%wg9s.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1301679733.1301682444.26035.gz
Rev3 WINNT 5.1 mozilla-central debug test reftest on 2011/04/01 10:42:13

s: talos-r3-xp-022
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 17 Treeherder Robot 2011-04-08 15:23:33 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1302283030.1302285686.12404.gz
Rev3 WINNT 5.1 tracemonkey debug test reftest on 2011/04/08 10:17:10

s: talos-r3-xp-053
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 18 Treeherder Robot 2011-04-11 10:10:59 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Cedar/1302538098.1302540784.1042.gz
Rev3 WINNT 5.1 cedar debug test reftest on 2011/04/11 09:08:18

s: talos-r3-xp-028
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 19 Treeherder Robot 2011-04-12 12:54:07 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1302612648.1302614322.19875.gz
Rev3 WINNT 5.1 mozilla-aurora opt test reftest on 2011/04/12 05:50:48

s: talos-r3-xp-039
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 20 Treeherder Robot 2011-04-13 07:31:23 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox4.0/1302683353.1302686022.12115.gz
Rev3 WINNT 5.1 mozilla-2.0 debug test reftest on 2011/04/13 01:29:13

s: talos-r3-xp-014
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 21 Treeherder Robot 2011-04-14 19:58:54 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1302823011.1302824647.17938.gz
Rev3 WINNT 5.1 mozilla-aurora opt test reftest on 2011/04/14 16:16:51

s: talos-r3-xp-038
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 22 Treeherder Robot 2011-04-18 08:11:50 PDT
rcampbell%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Devtools/1303134497.1303137520.7827.gz
Rev3 WINNT 5.1 devtools debug test reftest on 2011/04/18 06:48:17

s: talos-r3-xp-033
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 23 Treeherder Robot 2011-04-18 22:44:07 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1303186959.1303189610.21411.gz
Rev3 WINNT 5.1 tracemonkey debug test reftest on 2011/04/18 21:22:39

s: talos-r3-xp-042
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 24 Treeherder Robot 2011-04-20 12:33:46 PDT
dholbert%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303323494.1303326262.25296.gz
Rev3 WINNT 5.1 mozilla-central debug test reftest on 2011/04/20 11:18:14

s: talos-r3-xp-032
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 25 Treeherder Robot 2011-04-20 22:50:15 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303343870.1303346446.23445.gz
Rev3 WINNT 5.1 mozilla-central debug test reftest on 2011/04/20 16:57:50

s: talos-r3-xp-004
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 26 Treeherder Robot 2011-04-21 07:33:53 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303394253.1303395799.25211.gz
Rev3 WINNT 5.1 mozilla-central opt test reftest on 2011/04/21 06:57:33

s: talos-r3-xp-016
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 27 Treeherder Robot 2011-04-21 08:05:40 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1303395655.1303397244.814.gz
Rev3 WINNT 5.1 mozilla-aurora opt test reftest on 2011/04/21 07:20:55

s: talos-r3-xp-033
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 28 Treeherder Robot 2011-04-26 12:20:14 PDT
rcampbell%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Devtools/1303832076.1303833709.31255.gz
Rev3 WINNT 5.1 devtools opt test reftest on 2011/04/26 08:34:36

s: talos-r3-xp-034
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
Comment 29 Daniel Holbert [:dholbert] 2011-04-26 12:44:53 PDT
NOTE: Every failure in 2011 (comment 9 - comment 28) has been on WINNT 5.1 (winxp, I think?), and those failures are a 2px difference, as opposed to the 43px difference in the original Win7 failure (in reftest log attachment 495040 [details]).

The 2 pixels that differ are the bottommost blue pixel in the bottom-left and bottom-right circles.
Comment 30 Treeherder Robot 2011-04-29 05:00:58 PDT
hsivonen%iki.fi
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1304059104.1304061729.13353.gz
Rev3 WINNT 5.1 mozilla-aurora debug test reftest on 2011/04/28 23:38:24

s: talos-r3-xp-014
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 31 Treeherder Robot 2011-05-01 06:31:01 PDT
bill%wg9s.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1304254722.1304256182.30885.gz
Rev3 WINNT 5.1 mozilla-central opt test reftest on 2011/05/01 05:58:42

s: talos-r3-xp-052
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
Comment 32 Treeherder Robot 2011-05-05 09:02:20 PDT
mounir
http://tinderbox.mozilla.org/showlog.cgi?log=Try/1304608003.1304610879.13195.gz
Rev3 WINNT 5.1 try debug test reftest on 2011/05/05 08:06:43

s: talos-r3-xp-004
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
Comment 33 Treeherder Robot 2011-05-05 20:46:29 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Cedar/1304636719.1304639570.29513.gz
Rev3 WINNT 5.1 cedar debug test reftest on 2011/05/05 16:05:19

s: talos-r3-xp-021
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
Comment 34 Treeherder Robot 2011-05-06 05:52:51 PDT
mounir
http://tinderbox.mozilla.org/showlog.cgi?log=Cedar/1304683813.1304685300.21324.gz
Rev3 WINNT 5.1 cedar opt test reftest on 2011/05/06 05:10:13

s: talos-r3-xp-035
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
Comment 35 Treeherder Robot 2011-05-08 14:20:42 PDT
mounir
http://tinderbox.mozilla.org/showlog.cgi?log=Cedar/1304876586.1304879351.5656.gz
Rev3 WINNT 5.1 cedar debug test reftest on 2011/05/08 10:43:06

s: talos-r3-xp-020
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
Comment 36 Treeherder Robot 2011-05-11 11:30:52 PDT
dtownsend%oxymoronical.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1305135225.1305138082.13971.gz
Rev3 WINNT 5.1 mozilla-central debug test reftest on 2011/05/11 10:33:45

s: talos-r3-xp-013
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
Comment 37 Treeherder Robot 2011-05-12 07:18:53 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1305206023.1305208718.22369.gz
Rev3 WINNT 5.1 mozilla-central debug test reftest on 2011/05/12 06:13:43

s: talos-r3-xp-024
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
Comment 38 Treeherder Robot 2011-05-12 09:32:25 PDT
mfinkle%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1305213959.1305215528.1339.gz
Rev3 WINNT 5.1 mozilla-central opt test reftest on 2011/05/12 08:25:59

s: talos-r3-xp-042
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
Comment 39 Treeherder Robot 2011-05-12 19:38:56 PDT
mrbkap%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1305250161.1305253147.22435.gz
Rev3 WINNT 5.1 tracemonkey debug test reftest on 2011/05/12 18:29:21

s: talos-r3-xp-039
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
Comment 40 Robert Longson 2011-05-13 02:19:16 PDT
Created attachment 532142 [details] [diff] [review]
possible fix

Looks like the failures are a few pixels at the red/blue boundary. If we use crispEdges that might help as we won't be blending any pixels and we're trying to test that the shapes animate not that the colours blend.
Comment 41 Daniel Holbert [:dholbert] 2011-05-13 10:27:12 PDT
Comment on attachment 532142 [details] [diff] [review]
possible fix

Seems worth a shot.
Comment 42 Treeherder Robot 2011-05-13 14:41:14 PDT
mak77%bonardo.net
http://tinderbox.mozilla.org/showlog.cgi?log=Places/1305315800.1305318938.23203.gz
Rev3 WINNT 5.1 places debug test reftest on 2011/05/13 12:43:20

s: talos-r3-xp-008
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
Comment 43 Treeherder Robot 2011-05-13 16:00:39 PDT
mak77%bonardo.net
http://tinderbox.mozilla.org/showlog.cgi?log=Places/1305324481.1305327208.764.gz
Rev3 WINNT 5.1 places debug test reftest on 2011/05/13 15:08:01

s: talos-r3-xp-048
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
Comment 44 Treeherder Robot 2011-05-13 17:07:32 PDT
dholbert%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Cedar/1305327633.1305330428.17117.gz
Rev3 WINNT 5.1 cedar debug test reftest on 2011/05/13 16:00:33

s: talos-r3-xp-046
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
Comment 45 Jonathan Watt [:jwatt] (catching up after vacation) 2011-05-14 06:49:27 PDT
Pushed http://hg.mozilla.org/mozilla-central/rev/3f21638a8c8e
Comment 46 Jonathan Watt [:jwatt] (catching up after vacation) 2011-05-14 06:51:36 PDT
The push above was for bug 583423, but the bug number mentioned in the patch was wrong.

The actual push for this bug is:

http://hg.mozilla.org/mozilla-central/rev/c1c2ade5b20b
Comment 47 :Ehsan Akhgari 2011-05-14 08:59:04 PDT
Thanks, Robert!  I'm going to mark this as FIXED for now, and we can reopen if it happens again.
Comment 48 Treeherder Robot 2011-05-26 14:41:51 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Beta/1306440383.1306443103.22119.gz
Rev3 WINNT 5.1 mozilla-beta debug test reftest on 2011/05/26 13:06:23

s: talos-r3-xp-053
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 49 Treeherder Robot 2011-05-27 07:37:59 PDT
jmaher%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Beta/1306503247.1306506250.15407.gz
Rev3 WINNT 5.1 mozilla-beta debug test reftest on 2011/05/27 06:34:07

s: talos-r3-xp-011
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 50 Treeherder Robot 2011-08-05 15:49:36 PDT
mbrubeck%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Release/1310094776.1310097674.1557.gz
Rev3 WINNT 5.1 mozilla-release debug test reftest on 2011/07/07 20:12:56

s: talos-r3-xp-038
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/svg/smil/anim-rect-rxry-1.svg | image comparison (==)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)

Note You need to log in before you can comment on or make changes to this bug.