Closed Bug 61655 Opened 19 years ago Closed 14 years ago

installChrome does not work through proxy & firewall.

Categories

(Core Graveyard :: Installer: XPInstall Engine, defect, P3, major)

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: chrisp, Unassigned)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS 5.6 sun4u; en-US; m18) Gecko/20001128
BuildID:    2000112821

Cannot use Netscape's Theme Park to install themes in Mozilla if
the browser is behind a firewall and uses a proxy.

Reproducible: Always
Steps to Reproduce:
0. Browser must be set up to use a proxy and must be behind a firewall.
1.Go to http://home.netscape.com/themes/index.html?cp=djuc7
2.Click on an Install Theme link.
3.Click on Yes button in "Do you want to install theme?" dialog.


Actual Results:  Error message in console:

Error loading URL javascript:installTheme('earlyblue.jar', 'earlyblue/0.3);:805303f5

Theme install dialog pops up and says Beginning FTP transaction and then either
goes away quickly and stays up indefinitely.	

Expected Results:  Theme should be downloaded and installed into browser.

I have the same problem on the PC nightly build as well.
Reporter are you still seeing this with the latest nightlies?
I get a different problem on Windows 2000 running build 2000121404:
1. Go to http://home.netscape.com/themes/index.html?cp=djuc7
2. Click on an "Import Theme" button
3. Click on the OK button in response to the dialog box.
Expected results: The theme is downloaded and installed.
Actual results: A dialog box that reads "Downloading..." flashes briefly (less 
than one second) and disappears. Nothing else happens, specifically, I get no 
messages of any kind in the JavaScript console.
Bug still occurs with Solaris nightly build 2000121421. 
Marking NEW as per comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 63433 has been marked as a duplicate of this bug. ***
Blocks: 62353
Component: Installer: XPInstall Engine → Networking: FTP
OS: Solaris → All
Hardware: Sun → All
As duplicate bug 63433 was seen on Sun/Solaris and PC/WinNT, setting Platform/OS 
to All/All, moving component to Networking: FTP and copying the dependency 
status of the meta bug.
sorry for the extra mail....forgot to cc self when adding comments earlier...
This needs to be clarified:

Is this a proxy or a firewall problem.

Please present the proxy prefs in you are using.

-> browser general - can someone who understands theme installs put it in the 
"right" component?
Assignee: dveditz → asa
Component: Networking: FTP → Browser-General
QA Contact: jimmylee → doronr
Summary: installChrome does not work through proxy → installChrome does not work through proxy & firewall.
taking a guess. ->XPInstaller
Assignee: asa → syd
Component: Browser-General → Installer: XPInstall Engine
QA Contact: doronr → jimmylee
Target Milestone: --- → M1
Target Milestone: M1 → Future
+qawanted, this problem i still not well-understood.
Keywords: qawanted
The duplicate is WFM.

What's going from this end? If you need proxy help, let me know.
*** Bug 212853 has been marked as a duplicate of this bug. ***
-> defaults

+cc darin
(does this stuff use it's own protocol handler?)
Assignee: syd → xpi-engine
Can someone still reproduce this? If so, can I get a NSPR log of the HTTP/FTP
activity?
Target Milestone: Future → ---
I'm gonna go way out on a limb and mark this WFM. If anyone can reproduce, just speak up and I'll be glad to reopen the bug.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
Keywords: qawanted
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.