TabCandy should properly nest tab items in group items and use CSS for its layout

RESOLVED WONTFIX

Status

defect
P2
normal
RESOLVED WONTFIX
9 years ago
3 years ago

People

(Reporter: bugzilla.mozilla.org, Unassigned)

Tracking

Trunk
Future
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101202 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101202 Firefox/4.0b8pre

Seeing various other bugs related to messed-up rendering of the tab view i wondered how this could even happen. After taking a look at the view with the dom inspector the problem became obvious:

Tab groups and tab items are all direct children of the body element instead of tab items being nested within their owner group items and all layouting seems to be done manually.

This is suboptimal for several reasons:
1. it complicates code, since all tab items have to be manually positioned to appear above their groups.
2. it doesn't make full use of retained layers. Consider a group being moved, all previews inside the group would retain their position relative to the group and thus the entire content could be retained and just moved around by compositing instead of moving around each individual item.
3. it makes it harder to style things via css (think of addons extending tabcandy)

Since TC is using a stripped-down version of jQuery, here's something that would not only obsolete any manual position in a group with a grid-layout but would also take care of sorting: http://jqueryui.com/demos/sortable/#display-grid

jQuery UI draggable/droppable could also take care of moving things from one group to another.

Stacked groups would be somewhat more complicated but could make use of CSS3 rotations and nth-child rules.


So most of the tab layouts could be expressed with 2 CSS global rules + 1 additional per-group rule.

Reproducible: Always
Blocks: 604213
Summary: TabCandy should properly nest tab items in group items → TabCandy should properly nest tab items in group items and use CSS for its layout
Version: unspecified → Trunk
This sounds great. Time-frame-wise, we're coming down to the wire and are going to concentrate on the existing perf work and fixing things that are broken.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Target Milestone: --- → Future
We're not going to address this with Panorama being slated for removal.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.