Status

()

Core
XBL
P3
normal
VERIFIED DUPLICATE of bug 61452
18 years ago
18 years ago

People

(Reporter: scottputterman, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I'm using 2000112908 NT and have crashed 4 times in XBL code.  Twice it happened
when typing in the Compose Window and twice it happened while scrolling the
browser.  In the compose window the stacks is

       nsXBLWindowHandler::GetHandlers
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLWindowHandler.cpp, line 188]
     nsXBLWindowHandler::EnsureHandlers
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLWindowHandler.cpp, line 258]
     nsXBLWindowKeyHandler::EnsureHandlers
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLWindowKeyHandler.cpp, line 95]
     nsXBLWindowKeyHandler::WalkHandlers
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLWindowKeyHandler.cpp, line 115]
     nsXBLWindowKeyHandler::KeyDown
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLWindowKeyHandler.cpp, line 135]
     nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line
1171]
     nsWindowRoot::HandleChromeEvent
[d:\builds\seamonkey\mozilla\dom\src\base\nsWindowRoot.cpp, line 187]
     GlobalWindowImpl::HandleDOMEvent
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 582]
     nsXULDocument::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 2011]
     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3477]
     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3469]
     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3469]
     nsXULElement::HandleChromeEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 4417]
     GlobalWindowImpl::HandleDOMEvent
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 582]
     nsDocument::HandleDOMEvent
[d:\builds\seamonkey\mozilla\layout\base\src\nsDocument.cpp, line 3041]
     nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\layout\base\src\nsGenericElement.cpp, line 1419]
     nsHTMLTableCellElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\layout\html\content\src\nsHTMLTableCellElement.cpp,
line 525]
     PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4878]
     PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4813]
     nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 379]
     nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 352]
     nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 352]
     nsViewManager2::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1439]
     HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 68]
     nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 690]
     nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 707]
     nsWindow::DispatchKeyEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2298]
     nsWindow::OnKeyDown
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2334]
     nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2927]
<../images/spacer.gif>

For scrolling the stack is

       nsXBLPrototypeHandler::ExecuteHandler
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLPrototypeHandler.cpp, line 297]
     nsXBLWindowHandler::WalkHandlersInternal
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLWindowHandler.cpp, line 163]
     nsXBLWindowDragHandler::WalkHandlers
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLWindowDragHandler.cpp, line 110]
     nsXBLWindowDragHandler::DragGesture
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLWindowDragHandler.cpp, line 128]
     nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line
1530]
     nsWindowRoot::HandleChromeEvent
[d:\builds\seamonkey\mozilla\dom\src\base\nsWindowRoot.cpp, line 187]
     GlobalWindowImpl::HandleDOMEvent
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 582]
     nsXULDocument::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 2011]
     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3477]
     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3469]
     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3469]
     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3469]
     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3469]
     nsXULElement::HandleChromeEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 4417]
     GlobalWindowImpl::HandleDOMEvent
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 582]
     nsDocument::HandleDOMEvent
[d:\builds\seamonkey\mozilla\layout\base\src\nsDocument.cpp, line 3041]
     nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\layout\base\src\nsGenericElement.cpp, line 1419]
     nsHTMLTableCellElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\layout\html\content\src\nsHTMLTableCellElement.cpp,
line 525]
     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3469]
     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3469]
     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3469]
     nsEventStateManager::GenerateDragGesture
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 742]
     nsEventStateManager::PreHandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 300]
     PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4873]
     PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4813]
     nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 379]
     nsViewManager2::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1439]
     HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 68]
     nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 690]
     nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 707]
     nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3940]
     ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4148]
     nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2999]
     nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 963]
     USER32.dll + 0x1820 (0x77e71820)
     0x00b20357

Comment 1

18 years ago
First stack looks like bug 61452 (fix checked in yesterday afternoon).
Second stack looks like bug 61519 (fix checked in this afternoon). 
(Reporter)

Comment 2

18 years ago
you're right.  I will mark this as a dup of one of these.

*** This bug has been marked as a duplicate of 61452 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
*** Bug 61668 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.