Closed Bug 616638 Opened 13 years ago Closed 13 years ago

graphics corruption in fennec (repeated scale and copy/overwrite)

Categories

(Firefox for Android Graveyard :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(fennec2.0+)

RESOLVED DUPLICATE of bug 637828
Tracking Status
fennec 2.0+ ---

People

(Reporter: blassey, Assigned: jrmuizel)

References

Details

Attachments

(2 files)

Attached image screenshot
not sure how to describe other than it looks like we repeatedly self-copy while scaling and translating.
tracking-fennec: --- → ?
tracking-fennec: ? → 2.0+
Assignee: nobody → jmuizelaar
jeff, any ideas on how fix this?  Does GL make this magically better?
(In reply to comment #1)
> jeff, any ideas on how fix this?  Does GL make this magically better?

dougt you should be able to try it out by setting the layers-accelerate.all pref
Has anyone seen this recently?
Does this happen after fuzzy-zooming or another animation?  The screenshot looks suspiciously like a failure to clear a surface before rendering translucent content.
Bug 610344 also has "corruption" and that does happen after zooming - using the Form Helper.
need steps to reproduce
Could be related to bug 634759
See Also: → 634759
I still can't reproduce this.
Attached patch patchSplinter Review
I think this has gotten harder to reproduce as we've gotten faster, but I have been able to see it by repeatedly showing and hiding on this page http://lassey.us/show_hide.html

on a hunch I tried zero'ing out our shmem buffer when we create it, and with this patch I don't see this problem anymore
Attachment #515774 - Flags: review?(jones.chris.g)
Comment on attachment 515774 [details] [diff] [review]
patch

never mind, I just saw it again with this patch applied
Attachment #515774 - Flags: review?(jones.chris.g)
I tested google docs spreadsheets (which lately has been the most reliable way to reproduce this) with a build stechz provided me with an updated cairo and I cannot reproduce the problem with that build. Marking this as dependent on bug 562746 (Update cairo to 1.10).
Depends on: 562746
No longer depends on: 562746
Depends on: 562746
Whiteboard: [needs-cairo-update]
No longer depends on: 638594
Depends on: 637828
Whiteboard: [needs-cairo-update]
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.