Macedonian ciryllic transliteration is broken

RESOLVED WONTFIX

Status

support.mozilla.org
Knowledge Base Software
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: Novica Nakov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: 

When translating this article I noticed that the slug generated from the title of the article was missing a letter. In this case it was "њ" which should be transliterated into "nj".

After testing for the whole alphabet, here is the complete transliteration.
а - a
б - b
в - v
г - g
д - d
ѓ - gj
е - e
ж - zh
з - z
ѕ - dz
и - i
ј - j
к - k
л - l
љ - lj
м - m
н - n
њ - nj
о - o
п - p
р - r
с - s
т - t
ќ - kj
у - u
ф - f
х - h 
ц - c
ч - ch
џ - dj
ш - sh

Reproducible: Always
The slug field is prepopulated with a "best guess," using a simple algorithm that works fairly well for ASCII and low-Unicode Roman characters. Supporting alphabets beyond that was never intended.

You can edit the slug field, and it accepts any character, including Unicode, except "/". Whether you want to use the original character or a transliteration appropriate to the locale is presumably up to each locale.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.