Closed Bug 616716 Opened 10 years ago Closed 9 years ago

Firefox goes into offline mode on sleep, then hangs on quit

Categories

(Firefox :: General, defect, major)

x86
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 614958

People

(Reporter: notforyourmail, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101202 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101202 Firefox/4.0b8pre

This references bug 614958 and bug 615086.  I was asked to file a new bug if this still occurred.  The bug seems to have grown in scope, rather than being fixed.

When I quit Minefield, Minefield hangs and must be force quit.  Additionally, if my computer sleeps and then wakes up, Minefield behaves as if it were in offline mode, even though offline mode was never selected.  It then exhibits the same hanging behavior if I quit again.

Reproducible: Sometimes

Steps to Reproduce:
1.  Quit Minefield
2.  Minefield hangs and must be force-quit
3.  Or... Sleep computer
4.  Wake computer
5.  Network is up and working fine, but Minefield thinks it is offline.
6.  Minefield must be explicitly taken offline and online again, or it will hang on quit.
Actual Results:  
Minefield takes itself offline on sleep, then hangs on quit.  It also hangs on quit when not offline.

Expected Results:  
Minefield doesn't hang or take itself offline.
Ehsan: adding you to the CC list as requested.
I'm seeing similar issues in recent nightly builds. Seemed to start sometime in the last week or so.
>Gecko/20101202
Can you try it again with todays build because the patches in bug 614958 are from the same day as your build.
Hasn't happened yet with the latest build.
You've been testing a build without the fix to bug 614958, so it's really strange to expect the problem not happen!
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 614958
You need to log in before you can comment on or make changes to this bug.