About:addons should allow drag and drop of themes from the OS file explorer

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: will.pittenger1+mozbugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

548.66 KB, application/octet-stream
Details
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

I went to install a theme from my local hard drive.  It was a version not yet available online.  I was sent it via e-mail from the developer.  However, I was having problems getting about:addons to install it.   I tried all three of the following:

1. The Install Addon menu item inside about:addons itself--I was able to select the file, but nothing happened when it should have been offering to install the theme.
2. Dragging and dropping from Dolphin (this is Mandriva) to about:addons--about:addons doesn't appear to accept drag and drop
3. File/Open File--Firefox insisted on downloading the file even though it was already downloaded.  Would it install the theme?   No.  Even with Open in Browser (an extension) installed, it only offered to let me view the "page source".

Reproducible: Always

Steps to Reproduce:
1. Download, rather than install, a theme
2. Attempt to install it.
3.
Actual Results:  
Firefox b7 appears to only be able to install themes from the Internet, not your local hard drive.

Expected Results:  
Firefox should let you install extensions that you have cached on your local drive.
Works for me via both drag&drop and the "Install addon from file" menuitem. Tested by downloading a theme from AMO, and installing it from hard drive (I used https://addons.mozilla.org/en-US/firefox/addon/11861/).

I suspect it's something specific with the theme you're trying to install - could you verify that its properly packaged, etc? (Or possibly attach the file here?)
(Reporter)

Comment 2

8 years ago
Created attachment 495421 [details]
The theme I was using

Remember to save it locally and then install.
Also WFM with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0a2) Gecko/20110426 Firefox/5.0a2

Feel free to reopen if you can still see this issue with a recent Aurora build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.