bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Unable to download Seamonkey add-ons using Firefox

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED WONTFIX
8 years ago
3 years ago

People

(Reporter: krupa, Unassigned)

Tracking

Details

(Whiteboard: [z], URL)

(Reporter)

Description

8 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

steps to reproduce:
1. Load https://addons.allizom.org/en-US/seamonkey/addon/3284/ in FF 3.6.12
2. Click on "Download Now"

observed behavior:
Firefox tries to install the add-on

https://addons.allizom.org/seamonkey/downloads/latest/3284/addon-3284-latest.xpi?src=addondetail

Comment 1

8 years ago
Same problem on Linux, using Seamonkey.
It used to be possible, from the all versions page.
And is almost always possible on the few developer's sites who offer direct download.

Which means that one can't download for someone else.
One can't download a Firefox enabled addon for Seamonkey, even though it will work.
(Seamonkey 2.0 is compatible with Firefox 3.6)

If one can't download the xpi file, one can't make the very slight changes in permissions to allow Seamonkey install.
(Or Firefox, for Firefox install of addons with only Seamonkey permissions.)

As well, it would be nice to be able to save the xpi files, instead of discarding them.

This definitely should be fixed.

Comment 2

8 years ago
The same problem happens trying to install Novell Moonlight.
1. Load http://www.go-mono.com/moonlight/prerelease.aspx
2. Either click on download the Preview Release or the Nightly Build

A warning says Firefox blocked the installation of the software. Clicking on Permit after a minute another warning says it finished installing and needs a reboot. However after reboot nothing is installed.

Using Beta8.

Comment 3

8 years ago
One solution which would be very nice and user-friendly :

A separate button for "download and install" and "download".

1) Facilitates keeping a local copy of extensions installed.

2) Facilitates downloading for install on several user machines.

3) If there are problems with download-and-install, often they will disappear one the .xpi is on the local machine.  Since it will then be a local install.

4) For those with at least moderate programming skills, correcting a missing version line will allow installing an otherwise compatible Firefox-designated extension on Seamonkey, or the inverse on Firefox.

(Note that the navigator part of Seamonkey 2.0 is compatible with Firefox 3.6,
 and Sm 2.1 with Ff 4.0.)

Comment 4

8 years ago
item (3) should read :
... disappear _once_ the .xpi ...
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.