If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

{for} inside headings does not work in TOC

RESOLVED DUPLICATE of bug 628053

Status

support.mozilla.org
Knowledge Base Software
RESOLVED DUPLICATE of bug 628053
7 years ago
7 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
{for} inside headings does not work.
See:
https://support.mozilla.com/en-US/kb/Pop-up%20blocker
To clarify, {for} works fine inside the headings themselves, but fails to work in the table of contents:

== {for win}Windows{/for}{for mac}Mac{/for} ==

works as expected but the TOC shows "WindowsMac".

A workaround for now is to wrap the {for} around the whole heading:

{for mac,linux}
== Preferences Window ==
{/for}
{for win}
== Options Window ==
{/for}
(Reporter)

Comment 2

7 years ago
This workaround does not work for Windows because the Mac content is also displayed.
Maybe it is related to bug 616823 and the invisible {for}
(Reporter)

Comment 3

7 years ago
I don't know why but the workaround works now.

If I don't want to have a blank line before on Windows and after on Mac, Linux, how can I do because:
Example 1 shows nothing on Windows and both contents on Mac, Linux:
{for mac,linux}
== Preferences Window ==
{/for}{for win}
== Options Window ==
{/for}
Example 2 works:
{for mac,linux}Mac{/for}{for win}Windows{/for}
(Reporter)

Updated

7 years ago
Summary: {for} inside headings does not work → {for} inside headings does not work in TOC
Duplicate of this bug: 617566
(Reporter)

Comment 5

7 years ago
Dupe of bug 628053?
(In reply to comment #5)
> Dupe of bug 628053?

Ah, yes, I *knew* this bug existed when 628053 was filed but couldn't find it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 628053
You need to log in before you can comment on or make changes to this bug.