Closed Bug 616863 Opened 9 years ago Closed 9 years ago

comparison between signed and unsigned integer expressions in gfxFontUtils::FindPreferredSubtable

Categories

(Core :: Graphics, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 605179

People

(Reporter: timeless, Assigned: timeless)

Details

Attachments

(1 file)

gfx/thebes/gfxFontUtils.cpp:
 In static member function ‘static PRUint32 gfxFontUtils::FindPreferredSubtable(const PRUint8*, PRUint32, PRUint32*, PRUint32*, PRBool*)’:
535: warning: comparison between signed and unsigned integer expressions
So, i'm not really a fan of this.

The problem is that compilers are free to treat enums as signed or unsigned, this compiler treated them as signed. Here I'm casting 4 and 8 as unsigned 8 bit quantities, which is perfectly safe:
        SizeOfHeader = 4,
        SizeOfTable = 8,
Assignee: nobody → timeless
Status: NEW → ASSIGNED
Attachment #495389 - Flags: review?(jfkthame)
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 605179
Attachment #495389 - Flags: review?(jfkthame)
You need to log in before you can comment on or make changes to this bug.