<FONT><SELECT></FONT><OPTION>: Nav 4 compatibility

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: morse, Assigned: rickg)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
Go to above url.  Look at the select list for the state.  All the entries are
written as text below the list instead of being contained within the list.  Try
this with a 4.5 browser to see how it should be displayed.

Updated

20 years ago
Assignee: nisheeth → pollmann

Comment 1

20 years ago
Reassigning to Eric, the forms god...

Updated

20 years ago
Assignee: pollmann → rickg
Summary: Select list is not displayed correctly. → <FONT><SELECT></FONT><OPTION>: Nav 4 compatibility

Comment 2

20 years ago
The content model is being constructed such that the options are not children of
the select element.  Here is a snippet of the dump of the content model:
            ...
            td colspan=1 valign=top refcount=4<
              Text refcount=3<\n\t\t\t\t>
              font face=Verdana, Arial, Helvetica, sans-serif refcount=3<
                Text refcount=3<\n\t\t\t\t>
                input type=hidden name=QArray value=8 refcount=4<>
                Text refcount=3<\n\t\t\t\t>
                select name=8 refcount=4<
                >
              >
              Text refcount=3<\n\t\t\t\t\t\t\n\t\t\t\t\t\t>
              option value= refcount=3<
                Text refcount=3<(Please Select)\n\t\t\t\t\t\t>
              >
              option value=AL refcount=3<
                Text refcount=3<AL\n\t\t\t\t\t\t>
              >
              ...

This, as opposed to how it usually looks:
    ...
    select name=urls multiple= size=4 onchange=gotoURL() refcount=5<
      option id=a value= refcount=3<
        Text refcount=2<(Select a URL)>
      >
      option id=b value=http://www.yahoo.com refcount=3<
        Text refcount=2<http://www.yahoo.com>
     >
     ...

This appears to be caused by this nifty html:
   ...
   <FONT FACE="Verdana, Arial, Helvetica, sans-serif">
     <INPUT TYPE=HIDDEN NAME="QArray" VALUE="8">
     <SELECT NAME="8">
   </FONT>
        <OPTION VALUE="">(Please Select)
        <OPTION VALUE="AL">AL
        ...
     </SELECT>
   ...
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

20 years ago
Corrected by changes to parsing engine.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 4

20 years ago
Fixed in the June 2 Build.
You need to log in before you can comment on or make changes to this bug.