production builder throws 500 error when hitting the "test" button

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Add-on Builder
--
blocker
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
this is a blocker bug.
I guess cron is not running yet and disk is full...
Hmm, just tested out on of the add-ons I have on the new builder domain, and it worked as normal. Piotr, is the cron not running frequently enough or something?
Well, it worked for one of mine, and is now showing 500 for every new use of "Test".
Wil, I sent this your way because I figured you knew the most about the cron job that is running on the Builder, any thoughts as to what is wrong?
Assignee: nobody → clouserw
Are we talking about builder.mozillalabs.com? If so, then yeah, it ran out of disk space again. Fixed.

My understanding was this is no longer production?
Oh, I see bamo is doing this, disregard.
"My understanding was this is no longer production?"

We had integrated a cron to do the deletions, that apparently isn't running. This was unknown at the time of release, as the temp dir was not full so the app looked to be in good working order. We need to diagnose the reason that the cron is not properly deleting these old files.
This is to be run on 1.a6+ servers
/path/to/python /path/to/manage.py cron clean_tmp
(Reporter)

Comment 9

7 years ago
I'm getting both notifications from the builder now when i click "test", the 500 error and the "add-on installed" one.
(Reporter)

Comment 10

7 years ago
Hm, on another add-on i just got 500, and no install.

(This is all on BAMO).
First things first, lets run that build step a couple comments up that was missing from the build docs, then we can triage any further occurrence, if still present.

Updated

7 years ago
Assignee: clouserw → nobody
Depends on: 617116
Component: FlightDeck → Add-on Builder
Product: Mozilla Labs → addons.mozilla.org
Version: Trunk → unspecified
QA Contact: flightdeck → add-on-builder
Have had no indication this is still an issue for quite some time.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(In reply to comment #12)
> Have had no indication this is still an issue for quite some time.

Verified -- haven't seen anything like this lately, either.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.