Need 512x512 high res Firefox icon for Android marketplace

RESOLVED FIXED

Status

Marketing
Design
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Caitlin Looney, Assigned: John Slater)

Tracking

Details

Attachments

(6 attachments)

(Reporter)

Description

7 years ago
Need 512x512 high res Firefox icon for Android marketplace

The Android icon design guidelines located at http://developer.android.com/guide/practices/ui_guidelines/icon_design.html apply. -

Comment 1

7 years ago
Attaching two.  One with the R symbol, one without.  Both have the drop shadow.  Hope this helps...

Comment 2

7 years ago
Created attachment 495584 [details]
logos in Tiff
(Reporter)

Comment 3

7 years ago
Thanks a bunch!
(Assignee)

Comment 4

7 years ago
Thanks Tara!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 5

7 years ago
The correct guidelines for this image are here: http://market.android.com/support/bin/answer.py?answer=1078870

Specifically:
High Resolution Application Icon (Required):

    Use: In various locations in Android Market.
        Does not replace your launcher icon.
    Specs: 512x512, 32-bit PNG with alpha; Max size of 1024KB.
    Tips:
        This does not replace your launcher icon, but should be a higher-fidelity, higher-resolution version of your application icon.
        Same safe-frame as current launcher guidelines, just scaled up:
            Full Asset: 512 x 512 px.
            Circle or non-square icons: 426 x 426 px, centered within the PNG.
            Square Icons: 398 x 398 px.
        Drop shadow: black, 75% opaque, 90 degrees down, distance of 14px, size of 36px.
            Tweak as necessary to fit icon style (e.g., Google Maps icon has a drop shadow of varying height).



Would it be possible to get an image that fits the 426x426 guideline and is a transparent PNG rather than an opaque TIFF?  thanks!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 499111 [details]
PNGs of the Firefox icon, built to the described spec

Attached are two versions of a 426px icon in a 512px transparent PNG.  They're 24bit PNGs rather than 32bit PNGs -- that's all I could create in photoshop.

There are two versions.  One is the no shadow version of the Firefox icon. For the other, I've applied an Android Launcher-style drop-shadow, as described in the Android guidelines (I think this latter one looks better).
Created attachment 500068 [details]
App Logo 120x180 no alpha channel
Created attachment 500069 [details]
App Logo 120x180 alpha channel

Comment 9

7 years ago
I could be wrong, but I think the last two attachments are the old Firefox logo...
(Assignee)

Comment 10

7 years ago
That's correct. Those are most definitely the old logo.

The "new" logo is attached to comment #2, but you can also check it out at http://www.mozilla.com/en-US/press/media/logos/ or in various sizes at https://wiki.mozilla.org/Firefox3.6/Logos.
(Reporter)

Comment 11

7 years ago
So we still need the new logo with the updated requirements. John or Tara, can you help with this?
(Assignee)

Comment 12

7 years ago
Tara, can you work with Lee or whomever is available to get this fixed? Thanks!
(Assignee)

Comment 13

7 years ago
Btw, I just chatted with Caitlin and she's hoping to have this ready by Monday so Stuart can upload.

Comment 14

7 years ago
Caitlin, what are the updated requirements?  I had created a 512x512 high res. attachment earlier.  That didn't work?
(Assignee)

Comment 15

7 years ago
(In reply to comment #14)
> Caitlin, what are the updated requirements?  I had created a 512x512 high res.
> attachment earlier.  That didn't work?

See comment #5. Specifically, looks like it needs to be a transparent PNG vs a TIFF.

Comment 16

7 years ago
Got it.  Will see if Lee can whip it up.  Thanks

Comment 17

7 years ago
Created attachment 502120 [details]
Firefox logo 426x426

Hi all,
- I used the spec for circle/non-square icon: 426x426 px
- I was also, only able to save as a transparent PNG at 24bit not 32bit
- the logo may appear a tad high /off center of the square. I did this to account for our ground shadow, so it doesn't get chopped off the bottom edge of the asset.

Comment 18

7 years ago
Thanks Lee.  Caitlin / Stuart... does this work for you ?

Comment 19

7 years ago
Hey guys.  Just checking in on this again.  Do you have what you need to move forward?
(Reporter)

Comment 20

7 years ago
Madhava - Is one of your attachments 180w x 120h opaque PNG logo? 

We need this as the current logo in the Android Market is the old log. Can someone (Tara, Lee or Madhava?) please help provide this graphic? Thanks a ton!

Comment 21

7 years ago
Created attachment 509035 [details]
180x120 FF logo

Caitlin, does this work ?  it's a basic PNG of the new logo sized to fit your stated specs.  Not sure if it requires any additional work, but I just made this.
(Reporter)

Comment 22

7 years ago
Thanks Tara. Stuart - does this do the trick?

Comment 23

7 years ago
Just to be clear, I didn't follow the specifications in comment 5/6.  I just resized the high res image of the logo in PSD, and saved as PNG.  Just FYI.   Anyway, let me know.  Signing off for the night....

Updated

7 years ago
Duplicate of this bug: 630731

Comment 25

7 years ago
Hey guys, can I close this bug?
(Reporter)

Comment 26

7 years ago
Yes.

Updated

7 years ago
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.