Closed Bug 617111 Opened 9 years ago Closed 9 years ago

Avoid initializing NSS at all costs (ts regression)

Categories

(Toolkit :: Places, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla2.0b9
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: sdwilsh, Assigned: sdwilsh)

References

Details

(Whiteboard: [fixed-in-places])

Attachments

(1 file, 1 obsolete file)

Attached patch v1.0 (obsolete) — Splinter Review
In bug 607117, we ended up initializing NSS during startup.  This is the cause of our current Ts regression, so we need to stop doing that.

Shaver suggested I steal jsmath.cpp's random number implementation if it works.  It looks to be a suitable PRNG implementation (https://mxr.mozilla.org/mozilla-central/source/js/src/jsmath.cpp#514), and this patch implements it for Places code.

If NSS initialization ever gets small enough, we can switch to using it again, but for now this will have to do.
Attachment #495598 - Flags: review?(dtownsend)
blocking2.0: --- → betaN+
Try server data (just running xpcshell since that will give us the coverage we want):
http://tbpl.mozilla.org/?tree=MozillaTry&rev=6b6ba188da29
Comment on attachment 495598 [details] [diff] [review]
v1.0

Looking closer at the output of our test for this, it looks like the last character in our guid is always K, which is not desireable.  Going to improve the test to catch this problem, and figure out what is up :(
Attachment #495598 - Attachment is obsolete: true
Attachment #495598 - Flags: review?(dtownsend)
Attached patch v2.0Splinter Review
Better approach.  Making sure this works on unix via the try server first though...
Comment on attachment 495679 [details] [diff] [review]
v2.0

Try server appears to be OK with this.
Attachment #495679 - Flags: review?(dietrich)
Is this confirmed on Places to resolve the regression?
Comment on attachment 495679 [details] [diff] [review]
v2.0

r=me
Attachment #495679 - Flags: review?(dietrich) → review+
(In reply to comment #5)
> Is this confirmed on Places to resolve the regression?
Past expiriemnts showed that it was, but after yesterday's merge, and early talos results with this patch, it didn't look like it.  I'll have more data later today.
Try server numbers show a small regression there still, which is annoying.  However this did make a bunch of the regression go away.

http://hg.mozilla.org/projects/places/rev/f0110c8264c8
Whiteboard: [fixed-in-places]
Blocks: 617423
http://hg.mozilla.org/mozilla-central/rev/f0110c8264c8
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b9
Depends on: 619902
You need to log in before you can comment on or make changes to this bug.