TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js | Test timed out

VERIFIED FIXED in Firefox 4.0b9

Status

()

defect
VERIFIED FIXED
9 years ago
7 years ago

People

(Reporter: zpao, Unassigned)

Tracking

({intermittent-failure})

Trunk
Firefox 4.0b9
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

TEST-START | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js | sanity check that tab has correct extData
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js | sanity check that tab has correct extData
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js | sanity check that tab has correct extData
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js | sanity check that tab has correct extData
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js | sanity check that tab has correct extData
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js | sanity check that tab doesn't have extData
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js | (overwriting) new data is stored in extData
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js | (hiding) tab data has hidden == true
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js | (adding) new data is stored in extData
TEST-INFO | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js | Console message: [JavaScript Error: "[Exception... "'Illegal value' when calling method: [nsISessionStore::deleteTabValue]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js :: progressCallback :: line 124"  data: no]" {file: "chrome://browser/content/tabbrowser.xml" line: 378}]
NEXT ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js | Test timed out
INFO TEST-END | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js | finished in 30096ms
NEXT ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js | Found a tab after previous test timed out: about:blank
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_607016.js | Found a tab after previous test timed out: about:blank

Looks like the test might be racing some something else
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
So this is certainly caused by racing.

I don't intend to back the test out since I'd much rather have it in. If it's happening too "mittent"ly then I'll disable the test. The code added isn't the problem, but the test did expose a legitimate problem (bug 617175), while also not being the greatest test - it could be racing even with that other bug fixed. I should be waiting for SSTabRestoring on each tab. Or ultimately, SSWindowStateReady (being added in bug 615394).
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Bug 617175 landed so that _should_ make this disappear. I'll leave it open for a bit longer though.
OS: Mac OS X → All
Hardware: x86 → All
Fixed by bug 617175, indeed.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b9
Status: RESOLVED → VERIFIED
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.