Reporting for components causes errors

RESOLVED DUPLICATE of bug 567953

Status

()

Bugzilla
Reporting/Charting
RESOLVED DUPLICATE of bug 567953
8 years ago
8 years ago

People

(Reporter: miketosh, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 (CK-xxxxxxxxxx) Firefox/3.6.12 (.NET CLR 3.5.30729)
Build Identifier: 

If you have components in products that have the same name, the reporting tool will show multiple rows for that component, as many as exist, whether the numbers belong to that component or not.

Reproducible: Always

Steps to Reproduce:
1. Create 3 products all with the same component
2. Create bugs against one of them
3. go to the report page and use components as your Y axis.

report.cgi?y_axis_field=component&cumulate=0&z_axis_field=&format=bar&x_axis_field=&query_format=report-graph&resolution=---&action=wrap
Actual Results:  
You get multiple rows/columns for each of the unique components with the same number in them.  If you have 5 bugs against product1, component 'ALL', and 6 products with a component 'ALL', the report will show you 6 rows, each with the same 5 bugs listed.

Expected Results:  
only one row.

I've fixed this with the following change to report.cgi:

At the top, call 
  use List::MoreUtils qw(uniq);

At the bottom, change old line:
     $fields{$field->name} = \@names ;
to be:
     $fields{$field->name} = [ uniq @names ];
(Reporter)

Comment 1

8 years ago
I can provide the two line patch, but I can't check it in.

Comment 2

8 years ago
Which version is that?
Severity: major → normal
(Reporter)

Comment 3

8 years ago
Bugzilla 4.0rc1, and trunk.  I think a change to Bugzilla::Field->legal_values may have caused this.

Comment 4

8 years ago
Is Bugzilla 3.6.3 also affected?
Version: unspecified → 4.0

Comment 5

8 years ago
This is actually a dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 567953
(Reporter)

Comment 6

8 years ago
(In reply to comment #4)
> Is Bugzilla 3.6.3 also affected?

No.  3.6* isn't affected, just 4.0rc1+.  If you'd like me to add a patch to 567953 for approval, just let me know.
You need to log in before you can comment on or make changes to this bug.