Closed Bug 617150 Opened 12 years ago Closed 12 years ago

Sync UI: Quota dialog should display "0 bytes" when no value present

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: Atoll, Assigned: philikon)

References

Details

Attachments

(1 file, 1 obsolete file)

Currently, the quota dialog displays a blank field when the collection_usage for a given collection (eg. Tabs or Passwords) is either "0", or not present in the collection_usage response at all.

Is this the desired behavior?  It looks broken when I don't know any better.

Steps to reproduce:

Create a new profile.  Bookmark a page.  Set up first time sync.  Wait for first sync to complete.  View quotas.

Expected result:

Passwords should show 0.0 KB.

Actual result:

Passwords is blank.
(In reply to comment #0)
> Currently, the quota dialog displays a blank field when the collection_usage
> for a given collection (eg. Tabs or Passwords) is either "0", or not present in
> the collection_usage response at all.
> 
> Is this the desired behavior?  It looks broken when I don't know any better.

Yeah I agree.

> Passwords should show 0.0 KB.

I'm not sure why it should be "0.0 KB" and not "0 KB" or "0 bytes". I'm using the download manager's formatting code and that shows a zero value as "0 bytes". It doesn't really matter anyway since the objective is to show *something* when the value isn't present or zero.
OS: Mac OS X → All
Hardware: x86 → All
Summary: quota dialog should display "0.0 KB" when no passwords or tabs present → Sync UI: Quota dialog should display "0 bytes" when no value present
Attached patch v1 (obsolete) — Splinter Review
Assignee: nobody → philipp
Attachment #498542 - Flags: review?(mconnor)
Attachment #498542 - Flags: review?(mconnor) → review+
Attachment #498542 - Flags: approval2.0?
Comment on attachment 498542 [details] [diff] [review]
v1

I'm not entirely happy with this patch: if we fail to get the info (e.g. in offline mode), we now display 0 bytes as well. That doesn't seem right. Will adjust that.
Attachment #498542 - Flags: approval2.0?
Attached patch v1.1Splinter Review
Don't set the labels to "0 bytes" if we couldn't get the quota info.
Attachment #498542 - Attachment is obsolete: true
Attachment #502127 - Flags: review?
Attachment #502127 - Flags: approval2.0?
Attachment #502127 - Flags: review? → review?(mconnor)
Attachment #502127 - Flags: review?(mconnor)
Attachment #502127 - Flags: review+
Attachment #502127 - Flags: approval2.0?
Attachment #502127 - Flags: approval2.0+
https://hg.mozilla.org/mozilla-central/rev/c833cf2e69ef
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Verified against trunk from 2011-01-14.
Status: RESOLVED → VERIFIED
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.