deleteTabValue doesn't use early access

VERIFIED FIXED in Firefox 4.0b9

Status

()

defect
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: zpao, Assigned: zpao)

Tracking

Trunk
Firefox 4.0b9
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

Attachments

(1 attachment, 1 obsolete attachment)

We've allowed values to be set and retrieved via "early access" but not removed. This is (partly) causing the race condition in bug 617117 that's causing a random orange.
Posted patch Patch v0.1 (obsolete) — Splinter Review
This fixed bug 617117 for me - I reproduced that by adding a bunch of tabs before trying to deleteTabValue.

This also comes with tests! Just added to the tests for bug 590268 since they had the infrastructure to test this. I had to wrap in a try-catch otherwise it would just die in the loop there and the tests as a whole would still pass. Added an extra check that we at least do one proper testing of the get/set/delete with early access.
Assignee: nobody → paul
Status: NEW → ASSIGNED
Attachment #495713 - Flags: review?(dietrich)
Bug 590268 was blocking+ and since this is mostly an extension of that bug, blocking? on this one too.
blocking2.0: --- → ?
blocking2.0: ? → betaN+
Attachment #495713 - Flags: review?(dietrich) → review+
Whiteboard: [has patch][can land]
s/is/ok/ to fix that failure from try (should never have been an is check!)
Attachment #495713 - Attachment is obsolete: true
Pushed http://hg.mozilla.org/mozilla-central/rev/8531d0ed4546
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [has patch][can land]
Target Milestone: --- → Firefox 4.0b9
Is there a way I can verify this bug?
(In reply to comment #5)
> Is there a way I can verify this bug?

test passes
Status: RESOLVED → VERIFIED

Updated

8 years ago
Blocks: 639772
You need to log in before you can comment on or make changes to this bug.