Status

Tamarin
Virtual Machine
--
enhancement
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Alex Macdonald, Unassigned)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

92.63 KB, patch
Steven Johnson
: review+
Details | Diff | Splinter Review
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_5; en-us) AppleWebKit/533.19.4 (KHTML, like Gecko) Version/5.0.3 Safari/533.19.4
Build Identifier: 

The diff looks gigantic but only because I fixed the whitespace and removed tabs throughout the file, view it ignoring ws to see the functional changes.

Some of the work to enable exact callmethod for aot required small changes to the argument coercion code used in cdecl and fixed some bugs with the size of the argdesc computation.

Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 495754 [details] [diff] [review]
Cdecl refactoring
Attachment #495754 - Flags: review?(stejohns)

Comment 2

8 years ago
(In reply to comment #0)
> The diff looks gigantic but only because I fixed the whitespace and removed
> tabs throughout the file, view it ignoring ws to see the functional changes.

For future reference, it's usually preferred to upload diffs without the whitespace fixes, and fix the whitespace when you push.

Updated

8 years ago
Attachment #495754 - Flags: review?(stejohns) → review+
(Reporter)

Updated

8 years ago
Blocks: 617254
(Reporter)

Comment 3

8 years ago
Created attachment 499003 [details] [diff] [review]
Cdecl refactoring
Attachment #495754 - Attachment is obsolete: true

Updated

8 years ago
Blocks: 616780
(Reporter)

Updated

8 years ago
Blocks: 620678

Updated

7 years ago
Attachment #499003 - Flags: review+

Comment 4

7 years ago
TR 5851:bb1d051d4827
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.