Cache SSL certificates and hilight when they change.

VERIFIED DUPLICATE of bug 471798

Status

()

enhancement
VERIFIED DUPLICATE of bug 471798
9 years ago
7 years ago

People

(Reporter: richard.connon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.12) Gecko/20101205 Gentoo Firefox/3.6.12
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.12) Gecko/20101205 Gentoo Firefox/3.6.12

Firefox should highlight if an SSL certificate changes for a site.
Possibly with options to only highlight if it changes a long time before it expires or if the authority changes.

Reproducible: Always

Steps to Reproduce:
1. Go to a site.
2. Man in the middle the site with another "valid" certificate.
3. Revisit the site.
Actual Results:  
The site is loaded silently with the MITM able to see the traffic.

Expected Results:  
Firefox should highlight that a certificate changed.

This functionality is implemented (albeit not very reliably) in the CertPatrol extension but it should be in the core.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 471798
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.