Closed Bug 61745 Opened 19 years ago Closed 19 years ago

Fallout from initial porting needs cleanup

Categories

(SeaMonkey :: Build Config, defect, P3)

All
NetBSD
defect

Tracking

(Not tracked)

VERIFIED FIXED
Future

People

(Reporter: martin, Assigned: cls)

References

Details

Attachments

(3 files)

The SHLIB_LDSTARTFILE/SHLIB_LDENDFILE hacks are not needed if we call the
toolchain with proper parameters. The attached patches provide these.
Attached patch configure.in fixSplinter Review
Setting milestones to Future.
Target Milestone: --- → Future
Why this bug is marked as future milestone?
There is a simple patch only affects to NetBSD.
All of my bugs which did not have an assigned milestone and I was not actively
working on got "Futured".  My only concern about the "simple" patches is that I
cannot verify them and compatibility with older netbsd releases is a mild
concern.  If someone else from the community wants to step up and verify these
patches, that would speed up things tremendously.
1.verification
I (and NetBSD.org) will verify the fixes.

2.compatibility
Some options are changed. There maybe a compatibility issue on some older 
release of NetBSD.
But NetBSD package system apply those patches before compiling and I didn't 
hear any complain about this.

I second taya's comment. This patches are all stuff from our pkgsrc packaging of
mozilla. Virtually noone builds mozilla outside of pkgsrc nowadays (which
currently probably will work only on i386 and macppc anyway), but quite a lot
people do it using pkgsrc. We build binary packages from pkgsrc for major
releases and these are all tested.
Patches checked in.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
*** Bug 70837 has been marked as a duplicate of this bug. ***
I could successfully build mozilla from latest source on i386.
Now I'm building on mac68k, but it will take a few days...
I will check arm32 and macppc
reassigning QA contact to Taya.
QA Contact: granrose → taya
I could build both ELF platform(i386) and a.out platform(mac68k)
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.