If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

new window briefly opens when typing in twitter box

RESOLVED DUPLICATE of bug 579488

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 579488
7 years ago
2 years ago

People

(Reporter: tnikkel, Unassigned)

Tracking

Trunk
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
After logging in to twitter typing in the tweet box you sometimes get a new window that opens very briefly and then closes.

Only seems to happen for me on Windows 7 (haven't tried mac).
(Reporter)

Comment 1

7 years ago
I got a regression range but I have almost zero confidence in it since when I tried to narrow the range using hourlies I got contradictory results.

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cd392793b0c0&tochange=ae74a11a7d98

If someone else wants to try finding the regression range that would be great (especially since we can narrow the range using the hourly archive at http://hourly-archive.localgho.st/hourly-archive2/ since it stores about 2 weeks of hourlies).
Keywords: regressionwindow-wanted

Comment 2

7 years ago
I also believe this is Windows 7 only. I've never seen it on XP.
(Reporter)

Comment 3

7 years ago
Created attachment 496084 [details]
testcase
(Reporter)

Comment 4

7 years ago
Using this testcase repeatedly triggering the go button I can reproduce much easier. And the problem appears in 3.6 too. I'm going to take a guess that I think what might be happening is that we are not responding quick enough and the Windows desktop composition engine detects that and tries to do something (the new window popping up is some kind of not responding window). And I guess the new window opening pops us out of the not responding state somehow.
(Reporter)

Comment 5

7 years ago
Bas, does comment 4 ring any bells or am I off in crazy land?

Comment 6

7 years ago
(In reply to comment #4)
> (the new window popping up is some kind of not responding window)

Yes, that would be Windows Explorer's "ghost" Not Responding window. I don't know about the ghost window's appearance reviving Firefox, but it doesn't sound implausible.
(Reporter)

Comment 7

7 years ago
I think this is just the slow twitter typing.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 579488
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.