Closed Bug 617514 Opened 14 years ago Closed 14 years ago

Hardware acceleration on Minefield builds after 20101206 cause very poor performances and high CPU usage on Mac

Categories

(Core :: Graphics, defect)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- final+

People

(Reporter: notforyourmail, Assigned: bjacob)

Details

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101206 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101206 Firefox/4.0b8pre

The latest build of Minefield has extremely poor performance on a Core Duo based Macbook Pro.  Performance is so bad that you can see individual images render, bookmark icons in the bookmarks bar appear individually, and trackpad scrolling "drop frames".  The problem does not appear to occur on a Core 2 Duo Macbook Pro or a Mac Pro on the same network.  The problem did not occur in the previous day's Minefield build.  That build ran very fast on the Core Duo.  Network activity (as indicated by the animation on tabs) appears to start and stop with large pauses.  All browser interaction is unusually slow.  The problem occurs even after rebooting the system, with Minefield being the only application running.  No other applications on the same machine appeared to have any problems.  The issue appears to be isolated to the current Minefield build.  No changes have been made to the affected machine between builds (other than installing the update itself, of course.)

Reproducible: Always

Steps to Reproduce:
1.  Run Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101206 Firefox/4.0b8pre
2.  Scrolling, page rendering, and network activity are all very slow on a Core Duo Macbook Pro, but not on other machines.
Actual Results:  
Scrolling, page rendering, and network activity are all very slow on a Core Duo Macbook Pro, but not on other machines.  Performance is similar to a series of 1 second hangs.

Expected Results:  
Minefield responds, renders, and downloads rapidly, as it usually does on the same machine.
Same problem here, but I'm using an iMac with Intel Core 2 Duo 2,16 GHz with 10.6.5. Changing the subject accordingly.

Build id: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101207 Firefox/4.0b8pre

Even typing a single character in this text area push the CPU usage to 100%. Completely unusable.

To solve I had to disable the hardware acceleration in Prefs-Advanced. Does this work for you?
Summary: Latest Minefield build has very poor performance on a Core Duo Macbook Pro → Minefield builds after 20101206 have very poor performances and high CPU usage
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Minefield builds after 20101206 have very poor performances and high CPU usage → Minefield builds after 20101206 have very poor performances and high CPU usage on Mac
Yes!  Disabling hardware acceleration in Preferences -> advanced does appear to significantly improve browser performance on that machine.
(In reply to comment #2)
> Yes!  Disabling hardware acceleration in Preferences -> advanced does appear to
> significantly improve browser performance on that machine.

Perfect. Changing the subject again from "Minefield builds after 20101206 have very poor performances and high CPU usage on Mac" to "Hardware acceleration on Minefield builds after 20101206 cause very poor performances and high CPU usage on Mac"
Summary: Minefield builds after 20101206 have very poor performances and high CPU usage on Mac → Hardware acceleration on Minefield builds after 20101206 cause very poor performances and high CPU usage on Mac
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
blocking2.0: --- → ?
I bet we're using software OpenGL on these computers. Can people affected please post the Graphics section of their about:support page?
On my Mac Pro, where performance is good:

Adapter Description0x21a00,0x20400Vendor ID1a00Device ID1a00Adapter RAMAdapter DriversDriver VersionDriver DateDirect2D EnabledBlocked on your graphics card because of unresolved driver issues.DirectWrite EnabledfalseGPU Accelerated Windows1/1 OpenGL
On my Core Duo Macbook Pro, where performance is bad (and acceleration has been disabled):
Adapter Description0x21900,0x20400Vendor ID1900Device ID1900Adapter RAMAdapter DriversDriver VersionDriver DateDirect2D EnabledBlocked on your graphics card because of unresolved driver issues.DirectWrite EnabledfalseGPU Accelerated Windows0/1
Same core duo Macbook Pro with hardware acceleration enabled:
Adapter Description0x21900,0x20400Vendor ID1900Device ID1900Adapter RAMAdapter DriversDriver VersionDriver DateDirect2D EnabledBlocked on your graphics card because of unresolved driver issues.DirectWrite EnabledfalseGPU Accelerated Windows1/1 OpenGL

(By the way, I get the same super high CPU usage while typing on the Macbook Pro with hardware accleration enabled.  It's definitely teh same problem.)
This is the configuration for a Macbook Pro on which it works with no problems:

Adapter Description0x22600,0x20400Vendor ID2600Device ID2600Adapter RAMAdapter DriversDriver VersionDriver DateDirect2D EnabledBlocked on your graphics card because of unresolved driver issues.DirectWrite EnabledfalseGPU Accelerated Windows1/1 OpenGL
Well, we definitely block your hardware, because it doesn't support some features we need. I guess we're accidentally falling back to software there.

This might be fixed as a side-effect of the patches in bug 617475, but if not, Benoit will need to look into this. :)
Assignee: nobody → bjacob
blocking2.0: ? → final+
In case it helps to have an additional report, I'm experiencing the same slowness on my MBP, with the same adapter:

Adapter Description0x21900,0x20400Vendor ID1900Device ID1900Adapter RAMAdapter DriversDriver VersionDriver DateDirect2D EnabledBlocked on your graphics card because of unresolved driver issues.DirectWrite EnabledfalseGPU Accelerated Windows1/1 OpenGL
iMac (ATI Radeon X1600)

Adapter Description: 0x21900,0x20400
Vendor ID: 1900
Device ID: 1900
That matches the GPU on the Core Duo Macbook Pro:

 Chipset Model:	ATY,RadeonX1600
  Type:	GPU
  Bus:	PCIe
  PCIe Lane Width:	x16
  VRAM (Total):	128 MB
  Vendor:	ATI (0x1002)
  Device ID:	0x71c5
  Revision ID:	0x0000
(In reply to comment #5)
> On my Mac Pro, where performance is good:
> 
> Adapter Description0x21a00,0x20400Vendor ID1a00Device ID1a00Adapter RAMAdapter
> DriversDriver VersionDriver DateDirect2D EnabledBlocked on your graphics card
> because of unresolved driver issues.DirectWrite EnabledfalseGPU Accelerated
> Windows1/1 OpenGL

According to

http://developer.apple.com/library/mac/#documentation/GraphicsImaging/Reference/CGL_OpenGL/Reference/reference.html

adapter 0x21a00 means Radeon X2000 generation, that's a fast adapter with no known issues. So hardware acceleration works well, as expected.

(In reply to comment #6)
> On my Core Duo Macbook Pro, where performance is bad (and acceleration has been
> disabled):
> Adapter Description0x21900,0x20400Vendor ID1900Device ID1900Adapter RAMAdapter
> DriversDriver VersionDriver DateDirect2D EnabledBlocked on your graphics card
> because of unresolved driver issues.DirectWrite EnabledfalseGPU Accelerated
> Windows0/1

adapter 0x21900 means Radeon X1000 generation, these cards are known to be 'bad' in the sense that they can't render to FBOs where the color attachment is a NPOT texture. So the slowness when you enable hardware acceleration on these cards could have been just that it was using a software OpenGL fallback.

We've had code for a while to blacklist hardware acceleration on these cards, but it was incomplete. It received 2 big changes this week, the last one yesterday. Today's nightly build may behave differently from previous builds here. Can you please retry?
(In reply to comment #13)
> We've had code for a while to blacklist hardware acceleration on these cards,
> but it was incomplete. It received 2 big changes this week, the last one
> yesterday. Today's nightly build may behave differently from previous builds
> here. Can you please retry?

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101209 Firefox/4.0b8pre

Hardware acceleration pref is checked but it doesn't seem to be active (about:support tells me that I have 0/1 GPU accelerated windows).
I'm now using the latest build as of this morning (12/9/2010).  Performance seems much better with hardware acceleration checked on the Core Duo.  Looks like acceleration has been disable on that machine.  Might be good to grey out, or better yet, hide the checkbox option on blacklisted systems, since the option only makes sense on systems on which it can be enabled.

Adapter Description0x21900,0x20400Vendor ID0000Device ID0000Adapter RAMAdapter DriversDriver VersionDriver DateDirect2D EnabledfalseDirectWrite EnabledfalseGPU Accelerated Windows0/1
Yes, hardware acceleration is indeed disabled ("0/1") for you now.

The current phrasing says "when available", that's what it is for; I agree with you and guess that then we'd remove "when available" from this phrasing. Feel free to file a bug about this. But this is rather unlikely to be changed for Firefox 4.0 at this point.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
(In reply to comment #14)
> Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101209
> Firefox/4.0b8pre
> 
> Hardware acceleration pref is checked but it doesn't seem to be active
> (about:support tells me that I have 0/1 GPU accelerated windows).

Right, that's the correct behavior: radeon x1000 series are blacklisted as explained in comment 13.
I think the phrasing change is covered by bug 592919, no?
Indeed, I didn't know about that.
I should note, the acceleration changes don't seem to take effect until the browser is restarted.  If that is intentional, it should be indicated in some way.
Please add this comment to 592919, or it will get forgotten :-)
Heh.  Did that 2 minutes ago.  :-)
You need to log in before you can comment on or make changes to this bug.