If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash when navigating among POP/Local Folders.

VERIFIED DUPLICATE of bug 59617

Status

SeaMonkey
MailNews: Message Display
P3
blocker
VERIFIED DUPLICATE of bug 59617
17 years ago
13 years ago

People

(Reporter: Thao Tran, Assigned: scottputterman)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: suntrak-n6-highp)

(Reporter)

Description

17 years ago
Manipulting through local mail folders in Netscape will cause the browser to
crash (segmentation fault).When I create a Mail account, Local Folders will be
created for me in a default folder in .mozilla. I changed the directory to point
to the location of my local mail (which is in my home directory).  When I open
the Mail and manipulate through the mail boxes, the browser will crash.  The
point in which the crashes occur are random.  Somtimes it crashes when I move
from one folder to another, sometimes it takes moving through several folders
before the crash.  But it always seems to crash.  Then, I re-created my Local
Mail to point to the default (/home/thaot/.mozilla/thaot/Mail/Local Folders
directory, and netscape crashed as well.  It seems that no matter where I point
my local mail folers to, navigating through them will cause netscape to crash.

Here are the steps to recreate the occurence:
1) Create/re-create netscape mail.
2) Point local folders to which directory you have local folders.
3) If the location of the mail folders are different from what you set
previously, kill netscape and open a new one.
4) Open Mail again and naviagate back and forth between mail folders and email
messages in those folders.

Below is an inserpt of what the termail says that netscape is doing:
% ----------- Running Netscape 6 -------------
./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=.
  LD_LIBRARY_PATH=./Cool:.:/export/home/moz6.1116/dist/lib:/usr/openwin/lib
          LIBPATH=.:./Cool
       SHLIB_PATH=.:./Cool
      XPCS_HOME=./Cool
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
creating new nsJSAimChatRendezvous
Setting content window
*** Pulling out the charset
Loading page specified via openDialog
in SetSecurityButton
Document http://sunweb.central/ loaded successfully
we don't handle eBorderStyle_close yet... please fix me
start message pane with: http://messenger.netscape.com/bookmark/6/messengerstart
.html
In SortColumn
SetupCommandUpdateHandlers
in SetSecurityButton
stopping meteors 1
Document: Done (3.115secs)
stopping meteors
in showthreads
imap://thaot@ha3mpk-mail/INBOX
In ChangeFolderByURI uri = imap://thaot@ha3mpk-mail/INBOX
we don't handle eBorderStyle_close yet... please fix me
stopping meteors 1
Document: Done (4.537secs)
stopping meteors
In reroot folder
in showthreads
In SortColumn
We are looking for Sent
special folder name = Inbox
mailbox://nobody@Local%20Folders/Drafts
In ChangeFolderByURI uri = mailbox://nobody@Local%20Folders/Drafts
In reroot folder
in showthreads
In SortColumn
We are looking for Sent
special folder name = Drafts
mailbox://nobody@Local%20Folders/Templates
In ChangeFolderByURI uri = mailbox://nobody@Local%20Folders/Templates
Error loading with many headers to download: [Exception... "Component returned f
ailure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIMsgFolder.updateFolder]"
 nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)"  location: "JS frame :: chrom
e://messenger/content/commandglue.js :: ChangeFolderByURI :: line 190"  data: no
]
stopping meteors 1
Document: Done (0.163secs)
stopping meteors
In reroot folder
in showthreads
In SortColumn
We are looking for Sent
special folder name = Templates
mailbox://nobody@Local%20Folders/Sent
In ChangeFolderByURI uri = mailbox://nobody@Local%20Folders/Sent
Error loading with many headers to download: [Exception... "Component returned f
ailure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIMsgFolder.updateFolder]"
 nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)"  location: "JS frame :: chrom
e://messenger/content/commandglue.js :: ChangeFolderByURI :: line 190"  data: no
]
Segmentation Fault

[1]    Done                 ./netscape

Comment 1

17 years ago
Reporter, bugzilla is not the place to report bugs about Netscape 6, for that 
try Netscape's own bug-reporting form at Netscape's site. However if you can 
reproduce this with a latest build of Mozilla 
( ftp.mozilla.org/pub/mozilla/nightly ), a closer look will taken at the bug.
What do you call your "local mail"? Folders generated by earlier version of 
Netscape (like ns4)?
Thanky you,
Fabian.

Comment 2

17 years ago
adding suntracking string
Whiteboard: suntrak-n6-highp
reassign
Assignee: ducarroz → putterman
Component: Composition → Mail Window Front End

Comment 4

17 years ago
I'm pretty sure this is a duplicate of 59617...

Comment 5

17 years ago
Marking duplicate

*** This bug has been marked as a duplicate of 59617 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
QA Contact: esther → pmock
Resolution: --- → DUPLICATE
Summary: Local Mail Folders → Crash when navigating among POP/Local Folders.

Comment 6

17 years ago
Verified as a duplicate of bug 59617.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.