Memory leak and high CPU usage

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: filidautore, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 (.NET CLR 3.5.30729)

If I open the links present in the site http://animedblink.blogspot.com I see a lot of memory and CPU usage.
You can see the problem immediatly if you have a bunch of these site in the restart session.
It is very annoying.

Reproducible: Always

Steps to Reproduce:
1. Try to open these site:
http://animedblink.blogspot.com/2010/06/bleach.htm
http://animedblink.blogspot.com/2010/06/fairytail.html
http://animedblink.blogspot.com/2010/10/psychicdetectiveyakumo.html
http://animedblink.blogspot.com/2010/09/toloverutoraburu.html

2. You see memory increase and a lot of CPU usage

Actual Results:  
A lot of memory and CPU usage

Expected Results:  
Much less memory and CPU usage
(Reporter)

Updated

8 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Comment 1

8 years ago
In the first place I thought that the problem was connected with the OOPP so I changed the values dom.ipc.plugins.* to false in about:config but the problem was still there.

I tried even in safe-mode but the problem is still there.

(Maybe with only 4 tabs the problem is not so evident but with 25 is very inconvenient)
Summary: [OOPP] plugin_container use a lot of memory with high CPU → Memory leak and high CPU usage

Comment 2

8 years ago
Are you sure of those steps to reproduce?  Is that all?  Do you have to view streaming video to reproduce the problem?  I see no problem here on XP.

Comment 3

8 years ago
Cannot reproduce any bug.

Reporter acknowledges at http://forums.mozillazine.org/viewtopic.php?p=10346591#p10346591 that memory levels out with time.  VM levels out around 80 MB on my computer (930 MHz P III with 384 MB).  Web site has busy scripts plus feeds.  CPU levels out around 20-50%, but Chromium also uses 30% on my other, much faster Ubuntu computer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.