Crash dump after one operation of visualize the source page

RESOLVED FIXED

Status

SeaMonkey
General
P3
major
RESOLVED FIXED
17 years ago
7 years ago

People

(Reporter: alain.chappuis@medecine.unige.ch, Assigned: Colin Blake)

Tracking

Trunk
DEC
OpenVMS

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I would like to visualize the code source of one html page.
This bug is issued from my last enregistered bug where the
browser dont display the URL page.

See the produced dump:
-> *** Failed to preset charset menu for the view-source window
-> we don't handle eBorderStyle_close yet... please fix me
-> Setting content window
-> JavaScript error:
->  line 0: uncaught exception: [Exception... "Component returned failure code:
0x80004005
(NS_ERROR_FAILURE) [nsIWebNavigation.loaURI]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"
location: "JS frame :: chrome://navigator/content/viewsource.js ::
onLoadViewSource :: line 52"  data: no]
->
-> Document about:blank loaded successfully
-> %SYSTEM-F-ACCVIO, access violation, reason mask=00, virtual
address=1158000000000000,
PC=1158000000000000, PS=0000001B
-> %TRACE-F-TRACEBACK, symbolic stack dump follows
->   image    module    routine             line      rel PC           abs PC
->                                             0 0000000000000000
1158000000000000
->  LIBJSDOM  NSGLOBALWINDOW  Get_content  72440 0000000000009A78
000000000072C9B8
->  LIBMOZBRWSR  NSBROWSERINSTANCE  ReinitializeContentVariables
->                                         75396 000000000000594C
0000000001DAB94C
->  LIBMOZBRWSR  NSBROWSERINSTANCE  GetContentAreaDocShell
->                                         75416 0000000000005B18
0000000001DABB18
->  LIBMOZBRWSR  NSBROWSERINSTANCE  Close  76551 000000000000CEFC
0000000001DB2EFC
->  LIBMOZBRWSR  NSBROWSERINSTANCE  ~nsBrowserInstance
->                                         75380 000000000000565C
0000000001DAB65C
->  LIBMOZBRWSR  NSBROWSERINSTANCE  Release
->                                         75484 0000000000006428
0000000001DAC428
->  LIBXPCONNECT  XPCWRAPPEDNATIVE  ~nsXPCWrappedNative
->                                         45057 0000000000001398
000000000180CCA8
->  LIBXPCONNECT  XPCWRAPPEDNATIVE  Release
->                                         44730 00000000000005F4
000000000180BF04
->  LIBXPCONNECT  XPCWRAPPEDNATIVEJSOPS  WrappedNative_Finalize
->                                         45441 0000000000003574
0000000001814364
->  LIBMOZJS  JSOBJ  js_FinalizeObject     16575 000000000000362C
0000000000213F1C
->  LIBMOZJS  JSGC  gc_finalize_phase      14650 0000000000000DCC
00000000002001BC
->  LIBMOZJS  JSGC  js_GC                  14916 00000000000015C0
00000000002009B0
->  LIBMOZJS  JSGC  js_ForceGC             14614 0000000000000CEC
00000000002000DC
->  LIBMOZJS  JSCNTXT  js_DestroyContext   30227 00000000000004D0
00000000001E5AC0
->  LIBJSDOM  NSJSENVIRONMENT  ~nsJSContext
->                                         54497 00000000000034C4
000000000074F5A4
->  LIBJSDOM  NSJSENVIRONMENT  Release     54505 00000000000036F8
000000000074F7D8
->  LIBDOCSHELL  NSDOCSHELL  Destroy        9721 000000000001064C
0000000001A3E7DC
->  LIBDOCSHELL  NSWEBSHELL  Destroy       76395 000000000000B184
0000000001A57754
(Reporter)

Updated

17 years ago
Depends on: 61769
Target Milestone: --- → M18

Comment 1

17 years ago
How old is this build? There was an old bug about crashing when clicking the 
close button for view source. The milestone is for the developer.
Target Milestone: M18 → ---

Comment 2

17 years ago
Marking INVALID due to lack of response. Reporter feel free to reopen the bug if
you are still seeing this in the latest nightlies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 3

17 years ago
reopening and adding colin@theblakes.com
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Assignee)

Comment 4

17 years ago
We need to get the browser displaying the page first (61769) before we try to 
display the HTML for the page.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 5

17 years ago
reassign to self so it's Confirmed not accepted (i hope)
Status: ASSIGNED → NEW
(Assignee)

Comment 6

17 years ago
Sorry Asa, I thought this was already assigned to me!
Assignee: asa → colin
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 7

17 years ago
Alain, now that you have a good version of MultiNet, does this problem still 
exist, or can you view source now?
(Reporter)

Comment 8

17 years ago
This problem is resolved by update the old version of Multinet.
The new version of Multinet needed is 4.3 Rev A for M0.6
(Assignee)

Comment 9

17 years ago
Great news. Marking fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.