Closed Bug 617795 Opened 9 years ago Closed 9 years ago

Blank tab is not closed correctly when it is about:empty or is the only tab

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mbrubeck, Assigned: mbrubeck)

References

Details

(Keywords: polish)

Attachments

(2 files, 1 obsolete file)

Attached patch patch (obsolete) — Splinter Review
Steps to reproduce (thanks to a mibbit user on IRC):
1. Open a new tab.
2. Type "about:" in the urlbar and press enter.
3. Open the tab sidebar.

Expected results: No undo close tab button.

Actual results: Undo close tab button appears with a blank tab.

This happens because we initially create a remote tab showing about:blank, then destroy it to create a local tab for the about: page.

The patch fixes this by never showing "undo close tab" for about:blank. (It's just not that useful.)  It also fixes a similar bug where extra tabs are created when opening pages with the about:empty start page showing, and another related bug where the blank tab fails to close if there are no other tabs.
Attachment #496328 - Flags: review?(mark.finkle)
I think this is a dupe of bug 615271
Attached patch patchSplinter Review
(In reply to comment #1)
> I think this is a dupe of bug 615271

D'oh!  Yes, it is.  That fix looks good.  This new patch will apply on top of bug 615271, and only fixes the related bugs mentioned in comment 0.  I'll add a test later today too.
Attachment #496328 - Attachment is obsolete: true
Attachment #496489 - Flags: review?(mark.finkle)
Attachment #496328 - Flags: review?(mark.finkle)
Depends on: 615271
Summary: Mystery "undo close tab" appears when opening an about: page in a new tab → Blank tab is not closed correctly when it is about:empty or is the only tab
Attached patch testsSplinter Review
Attachment #496561 - Flags: review?(mark.finkle)
tracking-fennec: --- → ?
Attachment #496489 - Flags: review?(mark.finkle) → review+
Attachment #496561 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/7b714b5b4b11
http://hg.mozilla.org/mobile-browser/rev/e586736e3ac3
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
verified FIXED on build:
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b8pre) Gecko/20101210 Namoroka/4.0b8pre Fennec/4.0b3pre

and

Mozilla/5.0 (Android; Linux armv71; rv:2.0b8pre) Gecko/20101210 Namoroka/4.0b8pre Fennec/4.0b3pre
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.