Make it easy to enter a debugger when a test fails

RESOLVED DUPLICATE of bug 646343

Status

P1
normal
RESOLVED DUPLICATE of bug 646343
8 years ago
8 years ago

People

(Reporter: avarma, Unassigned)

Tracking

unspecified
1.0b5

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
One of the complaints that the JS team told me about when trying to fix broken Jetpack tests due to the compartments landing was that, unlike other Mozilla test suite infrastructure, it wasn't possible to enter gdb when a test failed, so they could inspect what went wrong.

I suspect it wouldn't be hard to add such functionality to the SDK's test runner/framework, and it seems like it'd be a big help to JS/Gecko engineers going forward.
Depends on: 646343
OS: Mac OS X → All
Priority: -- → P1
Hardware: x86 → All
Target Milestone: --- → 1.0b5
Status: NEW → RESOLVED
Last Resolved: 8 years ago
No longer depends on: 646343
Resolution: --- → DUPLICATE
Duplicate of bug: 646343
You need to log in before you can comment on or make changes to this bug.