enhancement: simple grouping of calendars

RESOLVED DUPLICATE of bug 255180

Status

--
enhancement
RESOLVED DUPLICATE of bug 255180
8 years ago
8 years ago

People

(Reporter: lbz, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.15) Gecko/20101028 Iceweasel/3.5.15 (like Firefox/3.5.15)
Build Identifier: 

A feature to act on (i.e. at least enable/disable) groups of calendars would be very helpful. In our example we have about 200 calendars (of a single person each), where each of them might belong to a number of groups.
the idea is to be able to quickly get an idea of calendar entries for all of the
 respective group's members (one group is (un)selected -> all members' calendars become (un)selected).
this is a different usecase than a group-calendar, as users generally won't enter each of their entries into both their personal and all group-calendars of the groups they belong to, and also as the information of which entry belongs to which specific user is meant to be preserved.

i actually tried to start implementing such a thing but kindof gave up after spending an excessive amount of time to (unsuccessfully) try to find out what kind of object "listTree" is, and whether that might be a better approach to adding groups to the calendar list/tree than by defining/implementing a new calendar type to add it to the composite calendar...
there's no such thing as a class reference, is there? :)


Reproducible: Always

Steps to Reproduce:
1. right-click on the "Calendar" pane
2. select "New Group" and add the calendars which should be in this group
3. see? ;)
Actual Results:  
people crying: "omg, the 'new group' menu-entry is missing!?"

Expected Results:  
a new entry in the "Calendar" pane that can be checked so that all "member-calendars" become checked, or unchecked so that all "member-calendars" become unchecked.

being able to query a group's members by ldap (i.e. instead of creating a local list by selecting from all available calendars, an option to configure ldap-server, basedn, filter, and attribute-name holding the calendar-name) would round it up close to perfection, i guess... :)
Looks like a duplicate of Bug 255180.
(Reporter)

Comment 2

8 years ago
Taking the last comment of 255180 (comment 9 by a. barsby) into account, this is a duplicate.
I did a search prior to creating this bug - don't know why i failed to find it, sorry.
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 255180
You need to log in before you can comment on or make changes to this bug.