History search UI should search for any change made between the two dates, not just last change

RESOLVED DUPLICATE of bug 294937

Status

()

RESOLVED DUPLICATE of bug 294937
8 years ago
5 years ago

People

(Reporter: gerv, Unassigned)

Tracking

Details

If you don't pick a field for the history search UI on the trunk, it defaults to searching for "Last Change Time" changed between X and Y. It is not immediately obvious that this is so. Because the dates are depicted as dependent on the field selection, it looks like you have to pick a field or fields if you want to put in dates.

We should:

a) add Last Change Time to the list of fields as the default option. This would also, for backwards compatibility, continue to be the default if nothing is selected.
b) add an "Anything" option
c) Add a "Comment Added" option (someone asked for this)

Gerv

Comment 1

8 years ago
Thanks for the suggestion. I'm more or less tempted to mark this bug as invalid, though, because it describes a solution instead of a problem. The best thing to do is to simply phrase the problem and then we should resolve that problem. Do you think you could rephrase the summary and description as just the problem you'd like to see resolved?
Observation: If you don't pick a field for the history search UI on the trunk, it defaults to searching for "Last Change Time" changed between X and Y. 

Problem: It is not immediately obvious from the UI that this is the behaviour. Firstly, because the dates are depicted as dependent on the field selection, it looks like you have to pick a field or fields if you want to put in dates (which is not true). But even if you get past that, the UI suggests that it will search for bugs where _any_ change was made between those dates, not bugs where the _last_ change was made between those dates.

Suggested Solution:

a) add Last Change Time to the list of fields as the default option. This would
also, for backwards compatibility, continue to be the default if nothing is
selected.
b) add an "Anything" option

Bonus feature to implement for someone working on this bug:

c) Add a "Comment Added" option

Is that better? :-)

Gerv
Summary: Improve UI for searching by history → History search UI is unclear

Comment 3

8 years ago
"History Search UI is unclear" is still a really vague summary. The whole UI isn't unclear. The UI, as a whole, is actually very clear.

What's the specific, actual problem that you personally encountered?
A summary is only a summary. The more detailed explanation of the problem is in comment 0, clarified in comment 2 under "Problem:". In short: the UI does not make it obvious that a particular type of search is possible, and when you do such a search anyway, is not sufficiently clear as to what is being searched for (it is easy to assume something other than what is the case). 

Gerv

Comment 5

8 years ago
Okay. So the UI defaults to searching for "Last Change Time". What did you expect it to search for instead? What was the behavior that you expected?
Max, I do know how to report a bug, and the information you are asking for is in the comments above, and I do think it's fairly clear. :-)

Comment 2 says: "But even if you get past that, the UI suggests that it
will search for bugs where _any_ change was made between those dates, not bugs
where the _last_ change was made between those dates."

From this, you can conclude that I expected it to search for "_any_ change was made between the dates given". 

To be painfully specific, the text around that section, on trunk, says:

"Search By Change History: Narrow results to how fields have changed during a specific time period"

So I expect that if I select no fields, it will search for _any_ field having changed, just as if I select no Statuses, it searches for bugs with any status, or if I put nothing in the URL field, it searches for bugs with any value for URL. Leaving a field blank means "Any" in the Bugzilla search UI.

Further, the box of fields to select is titled "where ANY of the fields:". If I select nothing, I should either be searching for "where NO fields changed" (although that, while a sane interpretation, would not be consistent with the rest of the UI) or "where ANY field changed". Defaulting to search for "when the last change was made" (or, equivalently, "when the Last Change Time field last changed") is not expected or suggested.

Gerv

Comment 7

8 years ago
Ah ha, I see now that you did indeed write "But even if you get past that, the UI suggests that it will search for bugs where _any_ change was made between those dates, not bugs where the _last_ change was made between those dates."

I agree that the existing UI should simply search for _any_ change made in between those dates, and if it doesn't, that's a bug.
Summary: History search UI is unclear → History search UI should search for any change made between the two dates, not just last change
By the way, the filing of this bug was partially triggered by bug 592163, comment 4.

Gerv

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 294937
You need to log in before you can comment on or make changes to this bug.