If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

FTP: Automatic Proxy Configuration broken

RESOLVED WORKSFORME

Status

()

Core
Networking
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: Stefan, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101122 Firefox/4.0b8pre

The first access to an FTP-URL bypasses the Proxy-Settings of an Automatic Proxy Configuration file at least if the URL is given on the command line or is opened from a bookmark.

Reproducible: Always

Steps to Reproduce:
0. Copy attachment "proxy.pac" to /tmp.
1. Open FF with fresh profile
2. Edit|Preferences|Advanced|Network|Settings|Automatic Proxy Configuration URL
   := "file:///tmp/proxy.pac"
3. ensure that nothing is listening on 127.0.0.3:23111
4. close FF.
5. On the command line execute: "firefox ftp://xmlsoft.org/libxslt" -> (1)
6. Bookmark the URL
7. Restart FF, click on bookmark -> (2)
8. Click again on bookmark -> (3)
Actual Results:  
(1), (2) FF connects directly to the ftp-server and renders the directory content.

(3) "The proxy server is refusing connections"

Expected Results:  
(1), (2), (3) "The proxy server is refusing connections"

Happens with mozilla-central from today and also with 3.5.15
(Reporter)

Comment 1

7 years ago
Created attachment 496502 [details]
Automatic Proxy Configuraration File "proxy.pac"

Updated

6 years ago
Version: unspecified → 4.0 Branch
This bug was reported using a pre-release version of Firefox 4. Now that Firefox 4.0.1 final has been released, can you please update and retest your bug? A fresh profile would be a good starting place to test, 
http://support.mozilla.com/kb/Managing+profiles. If you continue to see the issue, can you please update this bug with your results?

Filter: firefox4prebugsunco
(Reporter)

Comment 3

6 years ago
Issue reproduced with 
Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110603 Firefox/7.0a1
Version: 4.0 Branch → Trunk
We had some changes in the pac handling, does it still happen with Firefox18beta or later builds ?
Flags: needinfo?(kdevel)
(Reporter)

Comment 5

5 years ago
I can't test it due to Bug 723487:

XPCOMGlueLoad error for file ...firefox-18.0b6/firefox/libxpcom.so:
libxul.so: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

Nonetheless I would like to test the changes. Which commits/bugs implement them?
Flags: needinfo?(kdevel)
A possible incomplete query http://bit.ly/Vu0WIe
One rason why this bug report didn't get much attention is that it got never moved into the right component....
Component: General → Networking
Product: Firefox → Core
Attachment #496502 - Attachment mime type: application/octet-stream → text/plain
(Reporter)

Comment 7

5 years ago
(In reply to Matthias Versen [:Matti] from comment #4)
> We had some changes in the pac handling, does it still happen with
> Firefox18beta or later builds ?

I can no longer reproduce the issue, checked with "0d771761b9b3 tip".
great, marking wfm
Thanks for your response, the testing and the bug report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

4 years ago
The issue is back again in the 17.0.6esr version not only on FTP but also on HTTP and HTTPS. (was never fixed in 10esr or 17esr)

firefox-20.0a1-2013-01-11 does not show any of these issues.
You need to log in before you can comment on or make changes to this bug.