Closed Bug 618009 Opened 9 years ago Closed 9 years ago

add test for storage format detection during login

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: philikon, Assigned: rnewman)

References

Details

Attachments

(1 file)

We're bumping to storage format 5 for crypto changes. Ugprading a storage version 4 account gives me "Wrong Sync Key" rather than the outdated notification. Looks like the fix in bug 614737 wasn't much effective.

I think to save storage version 4 users we need to choose a different WBO for storage format 5. But we also need to make sure we will never run into this ever again by checking the storage version during login. (Login checks for HTTP 200/401 on info/collections, perhaps we can just switch it to meta/global and then analyze the contents on a 200. That way we don't have to fetch it separtely.)
Proposed name for new WBO:

  storage/crypto/bulkkeys

? Or should we change the collection, also? Better name suggestions welcome.

Working on earlier check and test harness for it now.
Severity: normal → blocker
Status: NEW → ASSIGNED
blocking2.0: --- → ?
tracking-fennec: --- → ?
See Also: → 614737
Will Firefox Home need to do something here as well?
Severity: blocker → normal
changing the collection makes this change much bigger, but maybe this looks like it's for the "bulkkeys" collection?

Could use "keys" instead.  keys/bulk for shortness win.a

Firefox Home will need to look for the new path, yes, so we need to lock that down first.
Severity: normal → blocker
Firefox Home correctly checks the storage version before syncing. Including for v4 vs v5 in Home 1.1

CHanges to Home only need to be made if we muck with names for records.
The attached test passes for me. Philipp is double-checking his repro.
Attachment #496563 - Flags: review?(mconnor)
I can't reproduce anymore. Must've been a messed up profile or something.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Can't reproduce, but I still want to add this test.
Severity: blocker → normal
Status: RESOLVED → REOPENED
blocking2.0: ? → ---
tracking-fennec: ? → ---
Resolution: WORKSFORME → ---
Summary: Need storage format detection during login → add test for storage format detection during login
Status: REOPENED → ASSIGNED
Attachment #496563 - Flags: review?(mconnor) → review+
Pushed: 

http://hg.mozilla.org/services/fx-sync/rev/4e55a139a835
Status: ASSIGNED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Blocks: 618492
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.