JM: Compile JSOP_CASE and JSOP_DEFAULT

RESOLVED DUPLICATE of bug 628073

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 628073
7 years ago
7 years ago

People

(Reporter: bhackett, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Switch statements which aren't optimized into LOOKUPSWITCH or TABLESWITCH get emitted as JSOP_CASE and JSOP_DEFAULT.  JSOP_CASE is a STRICTEQ plus IFNE, JSOP_DEFAULT is a POP plus GOTO, so these should be simple to do.
Duping forward (other bug has reviewed patch)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 628073
You need to log in before you can comment on or make changes to this bug.